Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Нарисовать блок-схему, и определить какие значения примут переменные "a", "b" и "c" в результате выполнения данного фрагмента алгоритма с начальными

10-11 класс

значениями a = 1, b = 3, c = 2.
для i:= 1 до 3
нц
b = - b
c = c + a*i
a = a - b
кц

Kaz919 11 мая 2014 г., 18:01:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sasha150350
11 мая 2014 г., 20:54:27 (10 лет назад)

ответ: a = 4; b = -3; c = 14

Ответить

Другие вопросы из категории

Правильно ли записаны числа в соответствующих системах счисления

А^10=А,234
А^8=-5678
А^16=456,46
А^3=22,2

Дан двумерный массив a размером n*n. Написать программу определения номера столбца с максимальной суммой элементов. Дан двумерный массив

а размером n*n. В каждой строке изменить значения элементов, стоящих за минимальным элементом этой строки, на 1

Даны два числа. Найти

среднее арифметическое кубов этих чисел.

Читайте также

1. Запишите следующее выражение по правилам программирования:



2. Выпишите недопустимые имена переменных:

a) Nomer;
b) S34;
c) И92;
d) Kol_vo54;
e) 45_A;
i) fg-л23

3. Установите соответствие (с помощью стрелок) между переменной и типом данных:

а) A:=3.234 а) Integer
b) Z:=14 b) Real
c) B:=10351 c) Byte
d) K:=-0.2 d) Word
e) C:= 64000

4. Запишите инструкцию:

а) присваивающую переменной V значение 7;

б) увеличивающую значение переменной Z на 30;

в) вычисляющую значение переменной R по формуле (X2+Y2):2;

5. Опишите переменные, необходимые для вычисления:


при x=-5.3, y=7.42

6. Напишите инструкцию вывода на экран:
а) вашего имени б) числа 400 в) значения выражения 7,3(3,22+8,61)

7. Определите, какое значение примет переменная С в результате выполнения данной последовательности операторов присваивания:

a:=8; b:=a/2; c:=43 mod a; a:=(b+c) div 6; b:=b+1; c:=sqrt(abs(a*b-14));

8. Установите соответствие между служебными словами и названиями разделов программы:

а) Var а) Раздел операторов
b) Program b) Раздел имени программы
c) Uses c) Раздел описания переменных
d) Begin …end d) Раздел описания библиотечных модулей

9. Найдите ошибки в записях оператора:

a) Write ©;
b) Writeln;
c) Writeln (Введите любое число);
d) Write X,Y;
e) WRITELN (‘воскресенье, нерабочий день’);

10. Какая структура программы верная:

begin
program MyFirst;
X:=Y+195;
end.


program MyProg;
begin
Writeln (‘Привет’);
end.

11. Расположите в правильном порядке строки программы, вычисляющей периметр и площадь параллелограмма:

1) S:=a*h;

6) var a,b,h,p,s: integer;

2) end.

7) readln;

3) program pr;

8) Writeln(‘p=’,p,’ s=’,s);

4) p:=2*(a+b);

9) a:=6;b:=3;h:=4;

5) Uses crt;

10) clrscr;

11) begin

12. Дан текст программы в таблице с ошибками:

исправьте ошибки в программе;что выведется на экран в результате выполнения программы?

Программа с ошибками

Программа без ошибок

На экране будет напечатано:

War: a,b,c – integer, x: real;
Bigin
A=7, b=3,2, c:=a+b;
Writln (summa=, c);
C:=c/2; x:=a-c;
Writeln(‘x=’ , x, ‘kvadrat=’, x*x);
and

13. Перевести блок-схему на язык Паскаль.

Вычисление расстояния между точками А и B.



Дан фрагмент программы. Нарисуйте блок-схему, восстановите вид формулы для расчета S

PASCAL:

VAR
A:ARRAY[1...100]OFF
INTEGER;
N,I,J: INTEGER;
S: REAL;
BTGIN
N:=8;
FOR I:=1 TO N DO
BEGIN
S:=0;
FOR J:=1 TO I DO
S:=S+(A[J]);
S:=ABS(S);
WRITELN(`S`=`,S:9:2);
END;
READLN;
END.

QBASIC
DEFINT N,I,J,S,
DIM A(100) AS INTEGER
N:=8
FOR I=1 TO N
S=0
FOR J=1 TO I
S=S+A[J]
NEXT J
S=ABS(S)
PRINT S
NEXT I

ШКОЛЬНЫЙ АЯ

алг слово(рез вещ s)
цел раб А[1:100]
n:=8
нц для I от 1 до n
s=0
нц для j от 1 до I
s=s+a[j]
кц
s=abs(s)
вывод s
кц
кон

Пожааалуйста нужны блок-схемы для трех вариантов получения s





Помогите пожалуйста! 1)Построить развлетвляющийся алгоритм, записать алгоритмы ввиде блок-схемы и на алгоритмическом языке. Треугольник задан

длинами своих сторон – a, b, c. Определить является ли

он тупоугольным, прямоугольным или остроугольным.

2) Построить циклический алгоритм, записать ввиде блок-схемы и на алгоритмическом языке.

Построить алгоритм, который определяет количество студентов в группе,
чей рост превышает среднее для группы значение.

Определить для массива X(n) алгебраические суммы четных и нечетных элементов массива. Вывести исходный массив и полученные значения. Упорядочить массив X(n

) по возрастанию. Вывести полученный массив. Исходный массив элементов получить с помощью датчика случайных чисел. Значения буквенных переменных задавать с клавиатуры.
Помогите написать программу в QBasic и нарисовать блок-схему(необязательно)

1)Найти 3 совершенное число(программа+блок схемы)

2)Определить 35 простое число(программа +блок схемы)
3)Дано:трехзначное число ,определить :является ли произведение его цифр трехзначным числом(программа+блок схемы)



Вы находитесь на странице вопроса "Нарисовать блок-схему, и определить какие значения примут переменные "a", "b" и "c" в результате выполнения данного фрагмента алгоритма с начальными", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.