Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите с одномерными массивами!

5-9 класс

Дан массив целых чисел.
а) все отрицательные элементы увеличьте на 10
б) выяснить, верно ли, что средних арифметических элементов больших 20, превышает 50.

Diroldirol 29 авг. 2013 г., 22:50:01 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Posya0125
29 авг. 2013 г., 23:59:18 (10 лет назад)

var a:array [1..100] of integer;
i,k, p, n:integer;
begin
p:=0;k:=0;
read (n); {количество элементов массива}
for i:=1 to n do
read(a[i]);
for i:=1 to n do
begin
if a[i]<0 then a[i]:=a[i]+10; {а}
if a[i]>20 then begin p:=p+a[i]; k:=k+1; end; {б}
end;
if p div k > 50 then writeln('yes'); {б}
for i:=1 to n dowrite (a[i], ' ');
end.

Ответить

Другие вопросы из категории

Помогите 4 и 5 задания умаляю
а) Укажите,как организованы следующие вложенные папки.

Музыка Рисунки
Тексты Фильмы

∞по принадлежности
∞по назначению
∞по содержимому
∞по времени создания
б)
Программы по математике Программы по информатике
Программы по географии Игровые программы
∞по принадлежности
∞по назначению
∞по содержимому
∞по времени создания
в) Работы Коли Работы Пети
Работы Руслана Работы Маши
∞по принадлежности
∞по назначению
∞по содержимому
∞по времени создания
г) 2011 2012
2013 2014
∞по принадлежности
∞по назначению
∞по содержимому
∞по времени создания
Просьба: отвечайте на все вопросы,которые содержаться в задании! Не надо сокращать ответы!

ПОМОГИТЕ СРОЧНО ПОЖАЛУЙСТА. РЕШИТЬ БЛОК-СХЕМОЙ

В трехзначном числе x зачеркнули его вторую цифру, когда к образованному при этом двузначному числу приписали вторую цифру числа x, то получилось число n. Найдите число x

Читайте также

УМОЛЯЮ,ПОМОГИТЕ!

1)Составить программу вывода на экран одномерного массива из пяти чисел,заполненного с клавиатуры

2)Составить программу вывода на экран одномерного массива из пяти чисел(числа в интервале от 0 до 100),заполненного случайным образом

3)найти минимальный элемент массива использованный случайным образом

Помогите пожалуйста.....

1.одномерные массивы

Напишите программу на Паскале.ВЫвести на экран номера всех элементов массива B[1..n],не совподающих с максимальным

помогите

Помогите пожалуйста:

1)В одномерном массиве А(15) найти процент отрицательных элементов.
2)

Помогите пожалуйста:

1)В одномерном массиве А(15) найти процент отрицательных элементов.
2)



Вы находитесь на странице вопроса "Помогите с одномерными массивами!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.