Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дано три числа - длина стороны квадрата и длины сторон прямоугольника. Определить, можно ли прямоугольник поместить в квадрат.

1-4 класс

Входные данные:
Во входном потоке задано три вещественных числа - сторона квадрата и стороны прямоугольника соответственно. Значение всех исходных величин не превышает 30000.

Выходные данные:
В выходной поток вывести 'YES' или 'NO'.

Пример входного файла
5 4 5
Пример выходного файла
YES

нина2012 14 сент. 2013 г., 8:46:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alina817
14 сент. 2013 г., 9:37:42 (10 лет назад)

var a,b,c:real;
begin
writeln('Vvedite 3 chisla');
readln(a,b,c);
if (a>=b) and (a>=c) then
  writeln('yes') elso
    writeln('no');
end.
примерно так, могут быть ошибки, но алгоритм ясен

Ответить

Читайте также

Составь алгоритм решения задачи:расположить три числа 32 17 24 в порядке возрастания:

1)Начало
2)Сравни первое и второе числа:если первое__________ второго то поменяй их местами.
3)Сравни второе третье числа если второе______ третьего то поменяй их местами
4) Если теперь три числа ___________ в порядке возрастания то исполни пункт 5)этого алгоритма
5)Конец

помогите пожалуйста составь алгоритм решения задачи расположить три числа 100 200 400 в порядке убывания 1) начало 2) сравни первое и

второе числа если первое...................................... второго , то поменяй их местами

3) сравни второе и третье числа если второе ......................................третьего ,то поменяй их местами

4) если теперь три числа ........................в порядке убывания, то исполни пункт 5) этого алгоритма иначе..........................к пункту 2)


Даны три вещественных числа x, y, z. Вычислить значения выражений x

+y+z и xyz и вывести максимальное из них



Вы находитесь на странице вопроса "Дано три числа - длина стороны квадрата и длины сторон прямоугольника. Определить, можно ли прямоугольник поместить в квадрат.", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.