Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составить программу, которая выводит на экран меню: 1) первое; 2) второе; 3) третье; и в зависимости от выбранного пункта вы

10-11 класс

даёт одну из надписей: «Получите суп», «Получите картошку», «Получите компот», «Оставайтесь голодным». Написать два варианта программы: с использованием условного оператора if и с использованием переключателя.

Alinako2004 15 янв. 2014 г., 12:35:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Marinadavid
15 янв. 2014 г., 13:27:19 (10 лет назад)



Program Atatushka1;
uses crt;
var
  M:Integer;
begin
  writeln('***************************************');
  writeln('*    Мы рады приветствовать вас       *');
  writeln('*         в нашем ресторане           *');
  writeln('*         A T A T U S H K A           *');
  writeln('*               ! ! !                 *');
  writeln('***************************************');
  writeln();
  writeln('***************************************');
  writeln('*              М Е Н Ю :              *');
  writeln('*  1. Первое                          *');
  writeln('*  2. Второе                          *');
  writeln('*  3. Третье                          *');
  writeln('*                                     *');
  writeln('***************************************');
  writeln();
  writeln('Введите номер желаемого блюда:');
  readln(M);
  writeln();
  if m=1 then
      writeln('Получите суп')
    else
      if m=2 then
          writeln('Получите картошку')
        else
          if m=3 then
              writeln('Получите компот')
            else
              writeln('Оставайтесь голодным');
end.

Program Atatushka2;
uses crt;
var
  M:Integer;
begin
  writeln('***************************************');
  writeln('*    Мы рады приветствовать вас       *');
  writeln('*         в нашем ресторане           *');
  writeln('*         A T A T U S H K A           *');
  writeln('*               ! ! !                 *');
  writeln('***************************************');
  writeln();
  writeln('***************************************');
  writeln('*              М Е Н Ю :              *');
  writeln('*  1. Первое                          *');
  writeln('*  2. Второе                          *');
  writeln('*  3. Третье                          *');
  writeln('*                                     *');
  writeln('***************************************');
  writeln();
  writeln('Введите номер желаемого блюда:');
  readln(M);
  writeln();
  case m of
    1: writeln('Получите суп');
    2: writeln('Получите картошку');
    3: writeln('Получите компот');
    else writeln('Оставайтесь голодным');
  end;
end.

+ 0 -
Allo5555542
15 янв. 2014 г., 16:05:54 (10 лет назад)

uses crt;
var m:integer;
begin
writeln('1) первое');
writeln('2) второе');
writeln('3) третье');
read(m);
if m=1 then write('получите суп');
if m=2 then write('получите картошку');
if m=3 then write('получите компот')
else write('оставайтесь голодным');
end.

 

uses crt;
var m:integer;
begin
writeln('1) первое');
writeln('2) второе');
writeln('3) третье');
read(m);
case m of
1:write('получите суп');
2:write('получите картошку');
3:write('получите компот');
else write('оставайтесь голодным');
end;
end.

Ответить

Другие вопросы из категории

Пожалуйста сделайте

Выполнить деление
a) 10010101111(2) : 1011(2)
б) 5366(8) : 27(8)
в) 690(16) : 14(16)

Здравствуйте ребят! Помогите решить задачку..Мне её надо написать в С++. Честно говоря хотя бы напишите мне "Дано" и как это решить.

=)

На концерте певицы было А % отдыхающих в санатории, на выступление хора зрителей собралось в 1,5 раза больше. Сколько зрителей побывало на этих концертах, если всего в санатории отдыхало х человек.

Читайте также

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

эллементы массива вычисляются по формуле A(X,Y)=2X^2-Y^2 написать программу, которая выводит на экран значения элементов массива А(2,2).

подсчитать количество отрицательных элементов

сумму положительных элементов

ВЫВОДИТ НА ЭКРАН НОМЕРА ВСЕХ ЭЛЕМЕНТОВ, ЗНАЧЕНИЯ КОТОРЫХ =0

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))



Вы находитесь на странице вопроса "Составить программу, которая выводит на экран меню: 1) первое; 2) второе; 3) третье; и в зависимости от выбранного пункта вы", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.