Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста сделать задачу в паскале АВС. Нужно первый элемент отрицательного массива заменить на ноль.

10-11 класс

Nastea243 01 апр. 2014 г., 23:20:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
карина2323
02 апр. 2014 г., 0:47:21 (10 лет назад)

var
  a: array [1..3] of shortint;
  i: byte;
  begin
  for i := 1 to 3 do
  begin
    a[i] := random(-1024, -1);
    writeln(String.Format('a[{0}] => {1}', i, a[i]));
  end;
  writeln();
  a[1] := 0;
  for i := 1 to 3 do writeln(String.Format('a[{0}] => {1}', i, a[i]));
end.

Ответить

Другие вопросы из категории

Как решить это в Excel?
инфо емкость стандартных cd-rom ?

1мб,1гб,650мбайт,650кбайт?

Помогите решить ребус хом ? клетка? сок
СРОЧНО!

Какого пункта меню нет в Блокноте?
а)Файл.
б)Правка.
в)Формат.
г)Вставка.

Читайте также

Помогите, пожалуйста, сделать задачи по информатике. Необходимо сделать на математическом языке и на паскале (желательно с объяснениями). Задача

2.

Все натуральные числа, начиная с 1, выписаны в одну строку без пробелов.Требуется написать программу, определяющую, какая цифра стоит в этой строке

на заданном месте.

Технические требования.

Имя входного файла: INPUT.TXT

Имя выходного файла: OUTPUT.TXT

Формат входных данных:

В единственной строке входного файла записано целое число N - длина слова (1 ≤ N≤ 100000000).

Формат выходных данных:

Выходной файл содержит одну искомую цифру.

Примеры файлов входных данных: Примеры файлов выходных данных:

21 5

Помогите, пожалуйста, решить задачи в паскале :

1.Определите сколько нечетных чисел среди четырех заданных чисел
2.Вычислите, является ли четырехзначное число счастливым

Помогите, пожалуйста, решить задачу в Паскале (программа выводит не правильный результат, а понять где допущены ошибки не могу).

Задать массив из 30 положительных элементов случайным образом.
• найти кол-во нечётных элементов всего массива;
• найти минимальный элемент;
• элементы, кратные 10, заменить единицами и вывести новый массив.

1. Дано n чисел. Найти колличество тех, которые делятся на 5, и не делятся на 7.

2. Найти квадраты всех отрицательных чисел среди N заданных.
3. Найти количество чисел, среди N введенных,которые имеют нечетные порядковые номера, а сами являются четными числам.
4. напишите программу для вычисления суммы:
- 1*1!+2*2!+3*3!+....+n*n!
- 1*3+3*5+5*7+...n(n+2)
- 1+11+111+...+111+1-n слагаемых.
Помогите, пожалуйста написать программы для паскаля, очень нужно. Заранее спасибо.



Вы находитесь на странице вопроса "Помогите пожалуйста сделать задачу в паскале АВС. Нужно первый элемент отрицательного массива заменить на ноль.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.