Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составить программу, которая вычесляет суммы элементов столбцов двумерного массива и записывает их в одномерный массив.

10-11 класс

Polina24 28 апр. 2015 г., 13:04:21 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Karsya
28 апр. 2015 г., 13:53:47 (9 лет назад)

var
  i,j:integer;
  a:array[1..5,1..10]of integer;
  b:array[1..10]of integer;
begin
for i:=1 to 5 do
  begin
  for j:=1 to 10 do
    begin
    a[i,j]:=random(10);
    write(a[i,j]:4);
    end;
  writeln;
  end;
writeln;
for j:=1 to 10 do
  begin
  for i:=1 to 5 do b[j]:=b[j]+a[i,j];
  write(b[j]:4);
  end;
end.

Ответить

Другие вопросы из категории

1)

Скорость передачи данных через модемное
соединение равна 51 200 бит/с. Передача текстового файла через это соединение
заняла 10 с. Определите, сколько символов содержал переданный текст, если
известно, что он был представлен в 16-битной кодировке Unicode.

Помогите написать код решения в паскале.

Кощей Бессмертный зарыл клад на глубину 1 м. Этого ему показалось не
достаточно, он отрыл клад, углубил колодец до 2 м и снова зарыл. Этого ему
опять показалось мало, он отрыл клад,
углубил колодец до 3 м
и зарыл. Затем он проделал тоже, углубив
колодец до 4 м, потом до 5 м, 6 м и т.д. Известно, что колодец глубиной

Помогите, пожалуйста, решить задачу:

Дан вектор из 25 элементов. Найти минимальное значение. Записать на языке Pascal и построить алгоритм.

Читайте также

Составить программу, которая вычисляет сумму элементов главной диагонали в

двумерном массиве размерности 3х3. Заполнить массив целыми случайными числами из
диапазона от 0 до 15.

1.Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .. 10] на 1. 2. составить программу, замены положительных

элементов настоящей таблице х [1 .. 10] на 0.

3.составить программу, замены отрицательного элементов настоящей таблице х [1 .. 10] на их квадрат.

4.составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .. 10], которые больше 10.

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

Работа с двумерными массивами.

Помогите написать программу, которая чётные элементы последовательности уменьшает в 2 раза, а нечётные увеличивает в 2 раза.
И ещё одна программа, которая находит сумму элементов, которые находятся под главной диагональю.
Заранее спасибо.



Вы находитесь на странице вопроса "Составить программу, которая вычесляет суммы элементов столбцов двумерного массива и записывает их в одномерный массив.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.