Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Срочно! Задача в Pascal. Условие:По введенному числу и основанию системы счисления определить существует ли такое число

10-11 класс

TelonkoWolf 07 дек. 2013 г., 21:09:19 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sanjkova
07 дек. 2013 г., 22:03:50 (10 лет назад)

uses crt;
var x,y,k: integer;
begin
     k:=0;
     write('Введите число: ');
     readln(x);
     write('Введите основание системы счисления: ');
     readln(y);
     while x>0 do
     begin
          if x mod 10=y then inc(k);
          x:=x div 10;
     end;
     if k>0 then writeln('Такого числа в этой системе не существует')
     else writeln('Такое число существует в данной системе счисления');
end.

Ответить

Другие вопросы из категории

Помогите решить 8 задачу.
Переведите на язык логических выражений следующие высказывания: 1) я поеду в Москву,и если встречу там друзей ,то мы интересно проведем

время.

2)если будет солнечная погода,то ребята пойдут в лес,а если будет пасмурная погода,то ребята пойдут в кино.

3) неверно,что если дует ветер,то солнце светит тогда,когда нет дождя.

4) если урок информатики будет интересным,то никто из школьников -Миша,Вика,Света-не будет смотреть в окно.:)

Читайте также

Ответьте на вопросы. 1) Какое минимальное основание может иметь система счисления, если в ней записано число 144701? 2) Какое

минимальное основание может иметь система счисления, если в ней записано число A11?

1.Переведите числа 25, 31, 37, 63, 85, 127, 128 в двоичную систему счисления.

2. Переведите числа 1000112, 1011012, 1101112, 10010112, 10111112, 11010012 в десятичнуюсистему счисления.
3. Сколько единиц в двоичной записи чисел 173, 195, 126, 208?
4. Сколько значащих нулей в двоичной записи чисел 48, 73, 96, 254?
5. Как по записи числа в двоичной системе счисления определить, что оно – четное? делитсяна 4? на 8? на 32?
6. Выполните сложение в двоичной системе:а) 10101112 + 1101012б) 10101112 + 1101012в) 1011012 + 111112г) 101112 + 1011102д) 1110112 + 110112е) 1110112 + 100112Для проверки повторите вычисления, переходя к десятичной системе, а потом преобразуярезультат обратно в двоичную.
7. Выполните вычитание в двоичной системе:а) 1011012 – 111112б) 110112 – 1101012г) 1010112 – 110112д) 10112 – 1001012 в) 101112 – 1011102 е) 10012 – 1011012Для проверки повторите вычисления, переходя к десятичной системе, а потом преобразуярезультат обратно в двоичную.
8. Переведите в двоичную систему числа 13,125; 23,25; 37,375; 48,625; 78,875.
9. Переведите в двоичную систему числа 11,8; 15,3; 22,7, выделив период в дробной части.
10. Требуется проверить, верно ли, что среднее арифметическое 100 целых чисел превышает0,2. Как сделать это, не используя операции с дробными числами?

СРОЧНО! ПОМОГИ! ПОЖАЛУЙСТА!!!!!! №1. В системе счисления с некоторым основанием десятичное число 43 записывается в виде «111». Укажите это

основание

№2. Укажите через запятую в порядке возрастания все основания систем счисления, в которых запись десятичного числа 53 оканчивается на 3.

№3. Укажите через запятую в порядке возрастания все числа, не превосходящие 30, запись которых в двоичной системе счисления оканчивается на «101». Числа в ответе указывайте в десятичной системе счисления.

№4. Количество единиц в двоичной записи числа 12, 25 равно…

№5. Для кодирования букв А,Б,В,Г решили использовать двухразрядные последовательные двоичные числа (от 00 до 11 соответственно). Если таким образом закодировать последовательность символов ГБАВ и перевести результат в шестнадцатеричную систему счисления, то получится…

№6. Как представляется десятичное число 13,5 в двоичной системе счисления?

№7. Как представляется десятичное число 416 в восьмеричной системе счисления?

№8. Как представляется десятичное число 523 в шестнадцатеричной системе счисления?

№9. Вычислите значение суммы 1012 + 118 + 1016. Результат представьте в виде десятичного числа.

№10. Вычислите значение разности двух чисел 1116 – 118. Результат представьте в виде десятичного числа.

100 пкт. Запись числа 281 в системе счисления с основанием n содержит 3 цифры и оканчивается на 1. чему равно максимально возможное основание системы

счисления.
Запись натурального числа в системах счисления с основанием 3 и 5 заканчивается на 0. найдите миним. натуральное число, удовлетворяющее этим условиям

1.чему равна сумма десятичного числа10 и двоичного числа 10 в десятичной системе счисления

1)20
2)12
3)21
4)1010
число 12 десятичной системы счисления в двоичной системе счисления имеет вид:
1)1000
2)1011
3)0010
4)0100
5)1100



Вы находитесь на странице вопроса "Срочно! Задача в Pascal. Условие:По введенному числу и основанию системы счисления определить существует ли такое число", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.