Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дано трехзначное число. Проверить, является ли число палиндромом, т.е. числом, которое читается одинаково слева направо и справа налево (число единиц

5-9 класс

может превосходить число сотен). Если не является, то вывести ближайшее следующее число-палиндром.

22200408 15 окт. 2014 г., 15:39:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Evelinamatveeva1982
15 окт. 2014 г., 16:26:10 (9 лет назад)

я на паре тестах попробывал вроде находит правильно, если найдешь варианты при которых будет выдавать неправильно то напиши в комментариях

+ 0 -
Zairaakbieva31
15 окт. 2014 г., 18:18:36 (9 лет назад)

Что не так?

+ 0 -
антонимая
15 окт. 2014 г., 20:33:08 (9 лет назад)

program uslovie;
var m,n,a,c: integer;
begin
readln(m);
if m div 100=m mod 10 then
writeln('Это число-палиндром')
else
begin
a:=m div 100;
c:=m mod 10;
n:=m+(a-c);
if a>c then
writeln(n)
else
n:=(m+10)-(c-a);
writeln(n)
end;
end.

Ответить

Другие вопросы из категории

Читайте также

Дано трехзначное число. напишите программу, которая определяет:

1) есть ли среди цифр заданного трехзначного числа одинаковые;
Пример входных данных
123 нет
121 да
222 да

2) является ли число '' перевертышем" , т.е. числом , десятичная запись которого читается одинаково слева направо и справа налево.
Пример входных данных
122 нет
121 перевертыш
222 перевертыш

Пожалуйста с примером!!!
Заранее большое спасибо

Помогите пожалуйста. программа Паскаль дано трехзначное число. Напишите программу, которая определяет: является ли число перевертышем, т.е числом,

десятичная запись которого читается одинаково слева направо и справа налево Пример входных данных: 122, 121, 222 Пример выходных данных: нет, перевертыш, перевертыш

Дано трёхзначное число. Напишите программу, которая определяет:

а) есть ли среди цифр заданного целого трёхзначного числа одинаковые;
пример входных данных: 123; 121; 222
пример выходных данных: нет; да; да
б) является ли число "перевёртышем", т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево.

1.Составьте программу, выводящую на экран все двухзначные числа, у которых сумма цифр равна 8.

2.Составьте программу вычисления количества трёхзначных чисел палиндромов ( чисел, которые читаются одинаково слева направо и справа налево).
3.Найти двухзначные числа, которые делятся на сумму своих цифр
4.Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.
РЕБЯТА СРОЧНО!!!!!!!!!!!

помогите решить пожалуйста, учитель бьется цветочком!

Составьте программу вычисления количества трехзначных чисел-палиндромов(чисел, которые читаются одинаково слева направо и справа налево).



Вы находитесь на странице вопроса "Дано трехзначное число. Проверить, является ли число палиндромом, т.е. числом, которое читается одинаково слева направо и справа налево (число единиц", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.