Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста )Срочно! Задача в Pascal. Введенное число возводится в квадрат, если оно большее 0 или не меняется. Нужно программу ( подробно) и блок-

10-11 класс

схему.

Maskarastor 17 мая 2013 г., 5:16:47 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Катюффка200326
17 мая 2013 г., 6:05:21 (11 лет назад)

var A:integer;
begin
writeln('Введи число');
readln(A);
if A>=0 then begin A:=A*A; writeln(A); end;
else writeln(A);
readln;
end.

+ 0 -
Krasopeto4ka94
17 мая 2013 г., 8:14:00 (11 лет назад)

var n:integer;
begin 
writeln('input n'); readln(n); 
 if n>0 then   
begin   
 n:=sqr(n);   
 writeln('n=',n);   
end 
else writeln('n<=0'); 
end. 
Думаю, с блок-схемой по программе проблем не будет.)

+ 0 -
Zarinaka97
17 мая 2013 г., 9:57:14 (11 лет назад)

если чило больше нуля то на выходе его квадрат, если число меньше= нулю то оно не меняется, т.е. на выходе то же число

+ 0 -
Larison252
17 мая 2013 г., 11:02:47 (11 лет назад)

я поняла так, что если число не меняется, то его нужно возвести в квадрат

+ 0 -
Akapulka
17 мая 2013 г., 13:11:59 (11 лет назад)

а когда число будет меняться?

+ 0 -
Dasha35
17 мая 2013 г., 15:13:43 (11 лет назад)

вот это я и не понимаю

+ 0 -
Adventure785
17 мая 2013 г., 17:54:11 (11 лет назад)

ну я поняла, что вот если мы ввели неотрицательное число, то мы возводим его в квадрат, иначе ничего с ним не делаем, т.е. не меняем. Но я могу быть не права

Ответить

Другие вопросы из категории

Начав тренировку лыжник в 1 день пробежал 10 км. Каждый след. день он увеличивал длину пробега на 10% от пробега предыдущего дня. Определить: а)в какой

день он пробежал больше 20 км. б) в какой день суммарный пробег за все дни превысит 100 км? Задача по информатике, надо составить программу в pascal abc. Помогите!

Дана последовательность целых положительных чисел. Найти произведение только тех чисел, которые больше заданного числа М. Если таких нет выдать

сообщение об этом.

На Паскале.

Срочно, и пожалуйста, без заумных команд, а так чтобы понятно было!

Читайте также

Помогите пожалуйста решить задачу в Pascal ( и если можно Блок схему ) . Найти произведение элементов массива, кратных 3 и 9. Размерность массива -10.

Заполнение массива осуществить случайными числами от 5 до 500. Срочном пожалуйста ребят !!

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

помогите пожалуйста решить задачи и закодировать их в программе visual foxpro 9.0!!!!!

1) определить время через которое встретятся два тела равноускоренно движущиеся навстречу друг другу,если известны их начальные скорости ускорения и начальное расстояние между ними.
2)даны целые числа m,n (0<m<или равно12,0<или равно n<60),указывающий момент времени:" m часов, n минут" .Определить наименьшеевремя(число полных минут),которое должно пройти до того момента когда часовая и минутная стрелки на циферблате совпадут.

ну оооочень нужно!!!!!!



Вы находитесь на странице вопроса "Помогите пожалуйста )Срочно! Задача в Pascal. Введенное число возводится в квадрат, если оно большее 0 или не меняется. Нужно программу ( подробно) и блок-", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.