Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

массив А(30) заполнить целыми случайными числами из (-7;25) вычислить полупроизведение всех положительных элементов. В Паскале. Нужно прям срочно. Буду

10-11 класс

очень благодарен.

Nikmar77 18 февр. 2014 г., 12:11:58 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Wika2004
18 февр. 2014 г., 13:09:28 (10 лет назад)

program task1;
const  n = 30;
var  a :array [1..n] of integer; 
 i, p :integer; 
pr :real;
begin
 randomize; 
 for i:= 1 to n do   
a[i]:= random(33)-7; 
p:= 1;  for i:= 1 to n do   
if a[i] > 0 then     
p:= p * a[i]; 
pr:= p/2; 
writeln(pr);
end.

program task2;
const  n = 30;
var  a: array [1..n] of integer; 
i, sum, max, min: integer; 
sr: real;
begin
randomize; 
for i := 1 to n do   
a[i] := random(33) - 7;   
sum:= 0; 
 for i := 1 to n do   
if a[i] >= 0 then     
sum:= sum + sqr(a[i]); 
min:= a[1];  max:= a[1]; 
for i := 1 to n do  begin   
if a[i] > max then max:= a[i];   
if a[i] < min then min:= a[i]; 
end; 
sr:= (max + min)/2; 
writeln('Сумма кадратов: ',sum); 
writeln('Среднее арифметическое: ',sr);  
end.

+ 0 -
Екатерина10021976
18 февр. 2014 г., 14:46:52 (10 лет назад)

массив А(30) заполнить целыми случайными числами из (-7;25)
вычислить:
1)сумму квадратов не отрицательных элементов
2)среднее арифметическое наиб и наим элементов массива

Ответить

Другие вопросы из категории

1. Получить все шестизначные числа, в диапазоне от 0 до 999999, у которых сумма первых трех цифр

равна сумме последних трех цифр. Если в числе меньше шести цифр, то оно слева дополняется нулями.

Помогите решить люди).

Подсчитайте количество нулевых элементов в массиве из 10 целых чисел и распечатайте исходный массив в обратном порядке.

Задание.Определить, сколько дней осталось от текущей даты до 31 декабря 2013 года: Для ввода сегодняшней даты используйте функцию

СЕГОДНЯ (категория - "Дата и время") Для вычисления разности межлу двумя датами используйте

Читайте также

Составить программу, которая вычисляет сумму элементов главной диагонали в

двумерном массиве размерности 3х3. Заполнить массив целыми случайными числами из
диапазона от 0 до 15.



Вы находитесь на странице вопроса "массив А(30) заполнить целыми случайными числами из (-7;25) вычислить полупроизведение всех положительных элементов. В Паскале. Нужно прям срочно. Буду", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.