Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помгите пожалуйста! Найдите ошибки, а то он всякую чепуху считает.Заранее большое спасибо)))) Используя команду ветвления составить программу,

5-9 класс

которая определяет, сколько чисел из К являются нечетными.

Program mass;

uses crt;

var i,k:integer;

a:array[1..100] of integer;

begin ClrScr;

k:=0;

randomize;

for i:=1 to 10 do begin

a[i]:=random(10)-5; write( a[i]:3);

if a[i] mod 2=1 then

k:=k+1;

end;

writeln ( 'Кол-во нечетных чисел из K ',k);

readln;

end.

Welom 25 февр. 2015 г., 20:02:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Анютик15072001
25 февр. 2015 г., 22:03:59 (9 лет назад)

Ошибка всего одна, для исправления нужно заменить: if a[i] mod 2=1  then  на  if abs(a[i]) mod 2=1  then .

+ 0 -
Lil789
25 февр. 2015 г., 23:02:47 (9 лет назад)

1) "сколько чисел из К являются  нечетными" - я так понимаю, эта фраза значит, что програма должна получить значение К, получить К чисел, и тогда посчитать количество нечетных чисел среди этих К чисел.

Если я прав, тогда нужно добавить ввод К.

2) строка if проверяет на нечетность только положительные числа, нужно добавить функцию abs

3) добавить строку writeln() без параметров, чтобы вывод информации "'Кол-во нечетных чисел из K" начинался с новой строки.

 

Ниже жирным выделено то, что нужно добавить, подчёркнуто то, что нужно удалить:

(переменная к - количество всех чисел, которые мы проверяем, kwo - количество нечётных чисел из к чисел):

 

Program mass;
uses crt;
var i,k,kwo:integer;  
  a:array[1..100] of integer;  
begin
  ClrScr;  
  k:=0;  

  kwo:=0; 
  write ('Введите К ');readln(k);

  randomize;
  for i:=1 to k 10   do begin  
    a[i]:=random(10)-5;  write( a[i]:3);
    if abs(a[i]) mod 2=1  then
    kwo:=kwo+1;

    k:=k+1;
 end;  
writeln ( 'Кол-во нечетных чисел из K ',k  kwo);  
readln;  
end.

Ответить

Другие вопросы из категории

Час Кода как пройти 10 уровень ам няма?
Девочки Аня,Маша и Варя купили себе флешки синего,белого и красного цветов.На вопрос,у кого из них какая флешка одна из девочек ответила: "У Аня флешка

синяя,у Маши-не синяя,а у Вари-не белая". Впоследствии выяснилось что в ответе верно сказано о цвете флешки только одной девочки. Какого цвета флешка у каждой из девочек? СПАСИБО ЗАРАНЕЕ!

Некоторое число в двоичной системе счисления записывается как 100110.

Определите это число и запишите его в ответе в десятичной системе
счисления.

Читайте также

Пожалуйста,мне нужно составить Алгоритм своего имени по Информатике

Алгоритм выглядит примерно так- Сместиться в точку ....
Опустить перо
Сместиться на вектор ...

Моё имя-Нурлан
Пожалуйста кто сможет напишите ) Заранее большое спасибо вам

Люди есть ли у кого ссылка на ответы к рабочей тетради,Л.Л. Босова и А.Ю. Босова 6 класс ФГОС??Если да скиньте пожалуйста.

А если нет,то ответьте пожалуйста:
512 битов-это:
1 килобайт это:
81920 битов:
заранее всем спасибо

Пожалуйста, помогите составить блок-схему по

 \frac{1}{1+a} + \frac{1}{1+b} ... + \frac{1}{1+n}
И, пожалуйста, если сможете, с объяснением.
Заранее большое спасибо.с:

Ребят кто-нибуть помогите

Знаете ли вы приложение на телефон где можно на одном фото поставить двух одинаковых человек( или разных но я хочу на каком то фоне поставить допустим там где я сижу и стою ) вот
Вобщем если кто то знает что то подобно то скажите ПОЖАЛУЙСТА название приложения
буду очень благодарна зарание БОЛЬШОЕ СПАСИБО !!!!

Помогите пожалуйста, срочно надо.

Заранее большое спасибо)
1) Определите и выведите на экран количество четырехзначных чисел, которые делятся без остатка одновременно на 5 и 11.
2) Найдите и выведите на экран все двузначные числа, у которых при умножения на 2 сумма цифр увеличивается на 5.



Вы находитесь на странице вопроса "Помгите пожалуйста! Найдите ошибки, а то он всякую чепуху считает.Заранее большое спасибо)))) Используя команду ветвления составить программу,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.