Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Прошу!!!Помогите решить эту задачу!Я знаю,что в начале надо писать програм пример,юсес срт,и чуть дальше,а другое не знаю :( Прошу!!

10-11 класс

Mihenson 06 апр. 2017 г., 18:49:56 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Undergr0und
06 апр. 2017 г., 21:49:30 (7 лет назад)

Uses CRT;
var
a,s:real;
begin
write('Введите сторону треугольника: ');
readln(a);
s:=a*a*sqrt(3)/4;
writeln('Площадь треугольника: ',s:3:4);
writeln('Радиус вписанной окружности: ',2*s/(3*a):3:4);
writeln('Радиус описанной окружности: ',a*a*a/(4*s):3:4);
end.

Ответить

Другие вопросы из категории

Текст рас­ска­за на­бран на ком­пью­те­ре. Ин­фор­ма­ци­он­ный объём по­лу­чив­ше­го­ся файла 15 Кбайт. Текст за­ни­ма­ет 10 стра­ниц, на каж­дой

стра­ни­це оди­на­ко­вое ко­ли­че­ство строк, в каж­дой стро­ке 64 сим­во­ла. Все сим­во­лы пред­став­ле­ны в ко­ди­ров­ке Unicode. В ис­поль­зу­е­мой вер­сии Unicode каж­дый сим­вол ко­ди­ру­ет­ся 2 бай­та­ми. Опре­де­ли­те, сколь­ко строк по­ме­ща­ет­ся на каж­дой стра­ни­це.

Читайте также

Здравствуйте, прошу помогите решить такое вот чудо.

Решить вроде бы нужно найти что за число вместо x.
Кто знает как правильнее прошу вашей помощи.
Чтобы просмотреть фото, кликните на него.

Здравствуйте. Помогите решить эту задачу в Pascal:

Найти минимальный среди максимальных элементов каждого из столбцов матриц С(5,10) и D(10,20). Задачу решить с использованием подпрограммы.

Очень прошу помогите с Паскалем!)

1. Напишите программу, вычисляющую площадь прямоугольника. С клавиатуры вводятся два действительных числа – стороны прямоугольника. Необходимо вычислить его площадь и вывести на экран. Вывод должен быть отформатирован следующим образом: под число отводится 10 знаков, а под вещественную часть – 3.
2. С клавиатуры вводятся 3 целых числа. Определить количество положительных чисел в этом наборе.
3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр.
4. С клавиатуры вводится натуральное число n. Узнайте в нем количество цифр.
5. С клавиатуры вводится натуральное число n. Посчитайте сумму S=1+2+…+n.
6. Даны целые положительные числа N и K. Используя только операции сложения и вычитания, найти частное от деления нацело N на K, а также остаток от этого деления.
7. С клавиатуры вводится натуральное число N. За ним последовательно вводятся данные о росте N учащихся класса. Определите средний рост учащихся всего класса. Попробуйте решить эту задачу без использования массивов.
8. Заполнить элементы массива последовательностью чисел: 2, 5, 10, 17, 26, …
9. Вводится число N, а за ним N целых чисел – элементов массива. Найдите количество отрицательных элементов в этом массиве.
10. С клавиатуры вводится число N. Выведите следующую фигуру (N-строк, на последней строке N звездочек). Подсказка: для решения этой задачи примените конструкцию «цикл в цикле».
*
* *
* * *
* * * *

* * * * * * *
11. Массив заполняется целыми числами до «нуля». Замените все положительные числа массив на противоположные им, а отрицательные возведите в квадрат. Выведите изменившийся массив.
12. На вход программе поступает целое число N. Выведите количество делителей N, включая 1 и само число N. Внимание: для решения этой задачи заведите счетчик и не забудьте сначала занести в него значение 0.

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.



Вы находитесь на странице вопроса "Прошу!!!Помогите решить эту задачу!Я знаю,что в начале надо писать програм пример,юсес срт,и чуть дальше,а другое не знаю :( Прошу!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.