Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1. Составить программу нахождения суммы чисел 5, 10, 15, 20, …50.

5-9 класс

2. Найти значения функции у= 5х+х2, при х=50, 49, 48, 47, …, 40.

Нафичка 02 мая 2013 г., 5:38:18 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vv0104
02 мая 2013 г., 8:33:24 (11 лет назад)

1) на языке С
#include <stdio.h>

int main()
{
float a1,an, d,Sn,n;
scanf("%f %f %f", &a1, &an, &d);
n=(an-a1+d)/d;
Sn=((a1+an)/2)*n;
printf("%0.1f", Sn);
return 0;


2) 

+ 0 -
настif
02 мая 2013 г., 10:08:39 (11 лет назад)

1) а) на Java
class example{
    public static void main (String[] args){
        int k = 0, j = 0;
        for (int i = 0; i < 10; i++){
            k = k + 5;
            j = j + k;
            if (i == 9)
            System.out.print(k);
            else
            System.out.print(k + " + ");
        }
        System.out.print(" = " + j);
    }
}
б) на Pascal
var a,b,c:integer;
begin
for a:=1 to 10 do
begin
b:=b+5;
c:=c+b;
if (a = 10) then write(b)
else write(b, ' + ')
end;
write(' = ', c);
end.
2) а) на Java
class example{
    public static void main(String args[]){
        for (int x = 50; x >= 40; x--){
        double y = (5 * x) + (Math.pow(x, 2));
        int i = (int) y;
        System.out.println(i);
        }
    }
}
б) на Pascal
var y:real;
x:integer;
begin
for x:=50 downto 40 do
begin
y:=(5*x)+sqr(x);
writeln(y:0:0);
end;
end.



+ 0 -
KarinaSengar
02 мая 2013 г., 11:22:58 (11 лет назад)

#include <stdio.h>

int main(){
float a1,an, d,Sn,n;
scanf("%f %f %f", &a1, &an, &d);
n=(an-a1+d)/d;
Sn=((a1+an)/2)*n;
printf("%0.1f", Sn);
return 0;
}
вводишь 5 50 5

+ 0 -
Bogash78
02 мая 2013 г., 13:31:00 (11 лет назад)

спасибо а 2 как решить?

+ 0 -
Dianakempel99
02 мая 2013 г., 15:10:32 (11 лет назад)

#include <stdio.h>

int main(){
int i;
for ( i=50;i>40;i--)
printf("%d\n", 5*i+i*i);
return 0;
}

Ответить

Другие вопросы из категории

Составьте блок-схему и программу решения следующей задачи. Три человека пообедали в ресторане. Официант подал счет на х рублей каждому. Они решают

оставить чаевые в размере 15% от счета. Найдите сумму чаевых , которую получил официант.

Помогите решить задачи 1. Какова мощность алфавита, если сообщение, содержащие 512 символов, занимает 1/2 часть Кбайта? 2. Сравните

объемы информации, содержащиеся в двух письмах. Первое письмо состоит из 50 символов 64-символьного алфавита, а второе из 40 символов 32-символьного алфавита.

1)найти сумму чисел кратные 3 но не делящихся на2 от 100 до 150

2)вывести натуральные числа от 100 до 150 через 5

Читайте также

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

1) составьте программу заполнения элементов массива [1..10 ] случайнымии целыми числами на отрезке [ 0;35 ] и вывода на экран нечетных элементов и

кратных числу 3.

2) составьте программу , которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 100 и выводит на экран среднее арифмитическое элементов массива

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно



Вы находитесь на странице вопроса "1. Составить программу нахождения суммы чисел 5, 10, 15, 20, …50.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.