Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите, пожалуйста, составить программу в паскале! Дано четырехзначное число заменить в нем наибольшую цифру нулем.

5-9 класс

Dtiplo 31 мая 2014 г., 10:25:06 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ириша122
31 мая 2014 г., 12:42:45 (9 лет назад)

var n,d,a,h,o,max:integer;
begin
readln(n);
d:=n div 1000;
h:=(n mod 1000) div 100;
a:= n mod 100 div 10 ;
o:=n mod 10; 
If (d>h) and (d>a) and  (d>o) then max:=d;
If (h>d) and (h>a) and  (h>o) then max:=h;
If (a>d) and (h<a) and  (a>o) then max:=a;
If (o>d) and (h<o) and  (a<o) then max:=o;
If d=max then writeln(0,h,a,o);
If h=max then writeln(d,0,a,o);
If a=max then writeln(d,h,0,o);
If o=max then writeln(d,h,a,0);
end.

Ответить

Другие вопросы из категории

Помогите пожалйста!Дали 6 слов,нужно оброзовать так чтобы получились слова:**буду благодарна очень)

ИТОМНРО , ГРАММПОРА , НЕРАСК,



ЛАНПШЕТ ЛВКАТУИРАА РОССЦЕПОР

Имеется кусок ткани длиной M метров. От него последовательно отрезаются куски разной длины. Все данные заносятся на компьютер. Компьютер должен выдать сооб

щение о том что материала не хватает, если будет затребован кусок ткани, большей длины чем имеется.
НА ПАСКАЛЕ, ПОДАЛУЙСТА

Читайте также

Помогите, пожалуйста, написать программу в Паскаль

Если дано трехзначное число, например 123 его можно представить в виде 3+2*10+1*10*10. Воспользовавшись этой информацией, создайте программу, которая, получая от пользователя трехзначное число, будет определять из каких цифр оно состоит и выводить их через пробел (например, 1_2_3).



Вы находитесь на странице вопроса "Помогите, пожалуйста, составить программу в паскале! Дано четырехзначное число заменить в нем наибольшую цифру нулем.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.