Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Определить сколько раз исполнится тело цикла и чему будет равно значение переменной 1) S:=18 for i:=5 to 3 do S:=S * 2; S:=S+2;

10-11 класс

2) S:=15; i:=5. while i<7 do begin i:=i+1 S:=S+S; end

3) S:= -6; i:=4

while i>8 do i:=i+1; S:=S * 0 .

Galina2002barabash 10 янв. 2015 г., 7:15:59 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gezihanov1997
10 янв. 2015 г., 9:06:14 (9 лет назад)

1) S:=18 for i:=5 to 3 do S:=S * 2; S:=S+2;

Цикл не выполнится ни разу. S = 20 (выполнится команда S:=S+2 после цикла)

 

2) S:=15;  i:=5.  while i<7 do begin i:=i+1  S:=S+S; end

Цикл выполнится 2 раза. S = 60

 

3)  S:= -6;  i:=4

while i>8 do i:=i+1;   S:=S * 0 .

Цикл не выполнится ни разу. S = 0 (выполнится команда S:=S * 0 после цикла)

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПОЖАЛУЙСТА

1."Вы выходите на следующей остановке?" -
спросили человека в автобусе.
"Нет", - ответил он. Сколько информации содержит ответ?
2. Какой объем информации содержит сообщение,
уменьшающее неопределенность знаний в 4 раза?


3. Вы подошли к светофору, когда горел желтый свет.
После этого загорелся зеленый. Какое количество информации Вы при этом
получили?


4. Группа школьников пришла в бассейн, в котором 4
дорожки для плавания. Тренер сообщил, что группа будет плавать на дорожке
№ 3. Сколько информации получили школьники из этого сообщения?


5. В корзине 8 шаров. Все шары разного цвета. Сколько
информации несет сообщение о том, что из корзины д7остали красный шар?


6.В библиотеке 16 стеллажей. На каждом стеллаже по 8
полок. Библиотекарь сказала Оле,
что интересующая ее книга, находится на 5 стеллаже, на 3й сверху полке сверху.
Какое количество информации получила Оля?


7. При угадывании целого числа в диапазоне от 1 до N было получено 4 бита
информации. Чему равно N?
8. Была получена телеграмма :"Встречайте, вагон 7". Известно, что в составе поезда 16 вагонов. Какое количество информации было получено
9.при угадывании целого числа в некотором диапазоне было получено 6 бит информации. Сколько чисел содержит этот диапазон?
10. сообщение о том, что ваш друг живет на 10м этаже, несет 4 бита информации. сколько этажей в доме?
сообщение о том, что петя живет во 2м подъезде, несет 3 бита информации. сколько подъездов в доме
11. в коробке лежат 7 разноцветных карандашей. какое количество информации содержит в себе сообщение , что из коробки достали красный карандаш?
12. какое количество информации несет сообщение:"встреча назначена на сентябрь"
13. какое количество информации несет сообщение о том, что встреча назначена на 15 число?
14. какое количество информации несет сообщение о том, что встреча назначена на 23 октября в 15:00
15. какое количество информации несет сообщение о том, что нужная вам программа находится на одной из восьми дискет
16. какое количество информации получит 2й игрок при игре в крестики-нолики на поле 8x8, после первого хода первого игрока, играющего крестиками?
17. в рулетке общее количество лунок равно 128. какое количество информации мы получаем в зрительном сообщении об остановке шарика в одной из лунок?
18. происходит выбор одной карты из колоды 32 карты. какое количество информации мы получаем в зрительном сообщении о выборе определенной карты?













Читайте также

Сколько раз выполнится тело цикла в каждом фрагменте программы?

1. For i :=1 to 7 do S := S + i * i;
2. For x := -3 to 5 do 5 do K := K+ABS(X);
3. For a := 10 downo 2 do P :=P*a;
4. For i := 2 to 6 do
begin
K:=K+1;
S:=K+i;
end;

Сколько раз выполнится тело цикла, и чему будут равны значения встречающихся в программе переменных после выполнения каждого фрагмента программы?

5. i :=2; S:=0;
While S<0 do begib S:= S+i; i:+2; end;

6. x:=1 ; S:=10 ;
While x <=10 do x:=x*2 ;
S:= S+x

7. a:=0; S:=0 ;
While a> 0 do S :=S +a;
a:=a+1;

8 . a:=1;
Repeat
R := 2*a;
a:= a+1 ;
until R < 1;

9. a:=1; b:=1;
While a+b < 8 do begin a :=a+1; b := b+2 end;
S := a+b;

10. S:=0; P:= 10; k:= 1;
Repeat
S:= S+k*k;
k :=k+2;
until S > P;

11. For i :=2 to 6 do begin
K:= K+1; S:= K+i;
end;

12. for i:= 1 to 4 do S :=S+i*i; S: S*2;

22. Дан фрагмент программы, обрабатывающий массив А из 10 элементов: n := 10; for i:=1 tо n do A[i] := i; j := 1; for i:=1 tо n-1 do if A[i] < A[i+1]

then j := j + 1; Чему будет равно значение переменной j после выполнения этого алгоритма?

Помогите с тестами по информатике!!! А1. Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 3 + 3*4;

b := (a div 10) + 4;

a := (b mod 10) + 2;

b:= a + b;

a:= a mod 2 + b div 3;

1) a=4, b=14;

2) a= 24, b= 6;

3) a=5, b=12;

4) a=8, b=12.

А2. Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1

2) 2

3) 3

4) 4

А3. Укажите, какое логическое выражение равносильно выражению ¬(A Ú ¬B Ú C) ?

1) ¬A Ú B Ú ¬C

2) A Ù ¬B Ù C

3) ¬A Ú ¬B Ú ¬C

4) ¬A Ù B Ù ¬C

X

Y

Z

F

1

1

1

1

1

1

0

1

1

0

1

1

А4. Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F (см. таблицу справа).

Какое выражение соответствует F?

1) X Ú ¬Y Ú Z

2) X Ù Y Ù Z

3) X Ù Y Ù ¬Z

4) ¬X Ú Y Ú ¬Z

А5. Что будет выведено на печать в результате выполнения следующих операторов:

a := 5; b := 10;

write( 'сумма двух чисел ' ); write( 'a+b' );

write( ' = ', a+b );

1) сумма двух чисел 5+10 = 15

2) сумма двух чисел a+b = 15

3) сумма двух чисел 5+10 = a+b

4) сумма двух чисел a+b = 5+10

5) ни один из ответов 1-4 не верен

А6. Чему было равно значение переменной a, если после выполнения операций

b := sqrt( sqr(a+1) );

c := -b;

a := 1 + 2 / (c-b);

она стала равна 0 ?

1) 2

2) 0

3) –1

4) любое вещ. число, не равное -1

5) ни один из ответов 1-4 не верен

А7. Чему будет равно значение А после выполнения цикла

а:=1024;

While a>0 do

a:=a / 2;

1) 0

2) 1

3) зациклится

4) 512

5) ни один из ответов 1-4 не верен

A8. Сколько раз выполнится тело цикла?

A:=32;

While A>2 do

Begin A:=A / 2; writeln(‘A’); end;

1) 8

2) 6

3) 5

4) 4

5) 3



Вы находитесь на странице вопроса "Определить сколько раз исполнится тело цикла и чему будет равно значение переменной 1) S:=18 for i:=5 to 3 do S:=S * 2; S:=S+2;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.