Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Скорость передачи данных по локальной сети запрашивается у пользователя и

5-9 класс

измеряется в битах в секунду. Ученик качал игру Т минут (время запрашивается у
пользователя). Рассчитайте и выведите на экран размер файла (в Гбайтах), который
скачал ученик и сколько денег придѐтся заплатить ему за трафик, если первый Гбайт
не оплачивается, а всѐ то, что сверху - по у рублей за Гбайт (запрашивается у
пользователя).

ЗАДАЧУ НУЖНО СДЕЛАВТЬ ЧЕРЕЗ PASCAL ABC

Babe27 07 мая 2015 г., 8:24:41 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Нася111
07 мая 2015 г., 9:20:05 (8 лет назад)

program z;
var t,u:integer; s,tr:real;
begin
writeln('Введите скорость'); read(u);
writeln('Введите время'); read(t);
writeln('Введите трафик'); read(tr);
s:=(u*t)/8388608;
if s>1 then tr:=s/tr;
writeln('Размер файла = ',s, ' Гб');
writeln('Оплата = ',tr, ' руб');
end.

Ответить

Читайте также

1) Скорость передачи данных по некоторому каналу связи равна 512 Кбит/с. Передача файла по этому каналу связи заняла 4 мин. Определите размер файла в

мегабайтах.

2) Скорость передачи данных по некоторому каналу связи равна 32 Кбит/с. Передача текстового файла по этому каналу связи заняла 15 с. Определите, сколько страниц содержал переданный текст, если известно, что иформационный вес одного символа равек 8 битам, а на одной странице 48 символов.

3) Скорость передачи данных по некоторому каналу равна 64000 бит/с. Передача файла по этому каналу связи заняла 16 с. Определите размер файла в килобайтах.

хотя бы первую решите....

С пояснениями пожалуйта .. Буду очень признательна

1)Передача данных через ADSL-соединение равна 256 000 бит/с. Передача файла через это соединение заняла 2 минуты. Определите размер файла в

килобайтах.

2)Скорость передачи данных через ADSL-соединение равна 64 000 бит/с. Сколько времени (в секундах) займет передача файла объемом 375 Кбайт по этому каналу?

3)Модем передает данные со скоростью 7680 бит/с. Передача текстового файла заняла 1,5 мин. Определите, сколько страниц содержал переданный текст, если известно, что он был представлен в 16-битной кодировке Unicode, а на одной странице – 400 символов.

1.Скорость передачи данных по некоторому каналу равна 256000 бит/с. Передач файла через это соединение заняла 1,5 мин. Определить размер файла в

килобайтах.
_______________________________________________________________________________

2.Информационное сообщение объемом 135 Мбайт передается со скоростью 128000 бит/с.
За сколько минут будет передано данное сообщение?



Вы находитесь на странице вопроса "Скорость передачи данных по локальной сети запрашивается у пользователя и", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.