Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составить программу к решению задачи : "дано число n. Найти сумму и количество его цифр.

5-9 класс

Nika98895070148 20 апр. 2014 г., 11:27:19 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Serelobanov201
20 апр. 2014 г., 13:49:13 (10 лет назад)

var a,b,k,c,d:integer;
begin
read(a); k:=0; c:=10;
while k<>0 do begin
b:=b + a mod c;  k:=a div c; inc(d);
end;
write(b,d);
end.

Ответить

Читайте также

1.Дано целое число составить программу которая определяет оканчивающие данное число цифрой семь.

2.Дано 2х значное число составить программу с помощью которой можно отпределить входит ли в это число цифра шесть.

Составить программу, определяющую, является ли данное утверждение истинным:Двузначное число А начинается на 3

Составить программу, определяющую, является ли данное утверждение истинным:Ровно одно из чисел А и В не превышает 100

Помогите, пожалуйста, решить самостоятельную:1.Составьте блок-схему и программу вычисления значения функции

(картинка дана ниже)

2.Составьте программу, определяющую, является ли данное число делителем числа 3.

3.Составьте программу, заменяющую меньшее из двух данных чисел суммой, а большее - произведением этих чисел.

Заранее спасибо.



Вы находитесь на странице вопроса "составить программу к решению задачи : "дано число n. Найти сумму и количество его цифр.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.