Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Pascal abc

5-9 класс

Напишите программу, которая возводит в квадрат введенное целое число, если оно отрицательное, и выводит на экран результат.

ЖенёкС 10 мая 2015 г., 12:08:23 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Мазека
10 мая 2015 г., 14:42:33 (9 лет назад)

program abc;
var i:integer;
begin
read(i);
if i<0 then
i:=sqr(i);
write(i);
end.

+ 0 -
Xyf1233
10 мая 2015 г., 15:49:46 (9 лет назад)

program kv;
  var a,x:integer;
   begin
   a:=0;
   read(x);
        if x<a then write(sqr(x)) else write('введено не отрицательное') ;
   end.

Ответить

Другие вопросы из категории

Помогите пожалуйста!!!!!
1. К системным относятся следующие программы: а) текстовый редактор б) графический редактор в) утилита архивирования файлов г)драйвер для клавиатуры 2.

Комплекс взаимосвязанных программ для обеспечения пользователю и программам удобного способа обращения называют : а) драйвером б) утилитой в) оболочка г) интерфейсом 3. Максимальное количество разрядов двоичного кода, которые могут передаваться и обрабатываться процессором одновременно, называют : а) адресным пространством б) разрядностью процессора в) ёмкостью ОЗУ г) регистрами

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC

Я работаю в прграмме Pascal ABC

Вот проверьте здесь гдето ошибка
program abc;
var a,b,c:integer;
begin;
write ('Длина равна=')
read(a);
write ('Ширина равна=')
read(b);
c:=a*b
write ('Площадь='c');
readln;
end.
Мне показало что в строке

Очень срочно. даю 100 пунктов. Pascal ABC. Если не сдам, будет 3 за четверть(((((((((((((( Написать программу, которая

сортирует массив ПО УБЫВАНИЮ и ищет в нем элемент, равный X (это число вводится с клавиатуры). Использовать двоичный поиск.



Вы находитесь на странице вопроса "Pascal abc", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.