Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Тема паскаль:

10-11 класс

Даны три массива A,B,C, состоящие из 10 элементов.Присвоить массиву D среднее арифметическое каждого элемента этих трех массивов.(4 стр, 10 столбцов, 0 до 10).Пожалуйста помогите кто умеет решать.Времени мало осталось.Заранее спасибо.
Например:
A B C D
1 2 3 (1+2+3)/3=2
2 3 4 (2+3+4)/3=3
3 4 5 (3+4+5)/3=4
4 5 6 (4+5+6)/3=5
5 6 7 (5+6+7)/3=6
6 7 8 (6+7+8)/3=7
7 8 9 (7+8+9)/3=8
8 9 10 (8+9+10)/3=9
9 10 11 (9+10+11)/3=10
10 11 12 (10+11+12)/3=11

Golowinanata 14 мая 2013 г., 20:10:19 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nelly96xocanyan
14 мая 2013 г., 21:29:33 (10 лет назад)

program sr;
const n=10;
var a,b,c:array[1..n] of integer;
    d:array[1..n] of real;
    i,k:integer;   
begin   
randomize;
for i:=1 to n do begin   
a[i]:=random(15);   
b[i]:=random(15);   
c[i]:=random(15);   
d[i]:=(a[i]+b[i]+c[i])/3   
end;   
for i:=1 to n do begin   
write (a[i],' ',b[i],' ',c[i],' ',d[i]:2:2);   
writeln;   
end;   
end.

Ответить

Другие вопросы из категории

сушествуют 3 действия Повернуть левый Повернуть правый диск по часовой стрелке Повернуть правый диск против часовой стрелки Повернуть левый

поворачивает левый диск на 180град Повернуть правый диск по часовой стрелке на 90град Повернуть правый диск против часовой стрелки на 90град

синий круг левый диск черыный - правый

превести мозайку в положение (во вложениях все)

награда 50 очков!

спасибо за решение

Читайте также

написать функцию,сравнивающую две даты.функция должна возвращать(-1) если первая дата меньше второй ,0- если первая и вторая даты одинаковы и 1

-если первая дата больше второй.паскаль.тема записи
в чем ошибка??
type date = record day: 1..31; month: 1..12; year: integer ; end;
var a: date := (day: 1; month: 4; year: 2015); b: date := (day: 1; month: 4; year: 2014); c:integer;

procedure OutDate(d: date);begin with d do writeln(day, '.', month, '.', year);end;
function Srawn(x, y: date): -1..1;beginif x.year > y.year then writeln( 1) else writeln(-1) ; if x.year = y.year then if x.month > y.month then writeln(1) else writeln(-1); if x.year = y.year then if x.month = y.month then if x.day > y.day then writeln(1) else writeln(-1); if x.year = y.year then if x.month = y.month then if x.day = y.day then writeln(0); end; begin OutDate(a); OutDate(b); c:=srawn(a,b); writeln('otwet:', c);end.

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!



Вы находитесь на странице вопроса "Тема паскаль:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.