Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дан массив из 15 эл. диапазон от 0 до 20 (случ. образом). дано целое число n>0. найти пару соседних элементов суммой равной заданному числу

10-11 класс

Евчик1 02 окт. 2013 г., 9:10:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastyarylko
02 окт. 2013 г., 10:02:41 (10 лет назад)

var

  a : array [1..15] of byte;

  i, res, n : byte;

begin

  for i := 1 to 15 do a[i] := trunc (random (21));

  res := 20;

  read (n);

  for i := 1 to 14 do

    if a[i] + a[i + 1] = n then res := i;

  if res = 20 then writeln ('Таких нет') else writeln (res, ' и ', res + 1);

end.

 

Число 20 точно не встретится, поэтому используется как показатель, что таких нет.

Ответить

Другие вопросы из категории

Решите в Pascal и Excel плиз
Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Ребята, девчата, тут такое затруднение. Нужна программа в паскале, только в паскале.

Условие:
Напишите программу которая вычисляет среднее арифметическое элементов таблицы А(3*8) . Программа по двумерным массивам.

Читайте также

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE

запишите заголовки цикла for для изменения параметра из диапазонов от -10 до +10______________________ от 100 до 1

_______________________

от 15 до 25 ________________________

от -10 до -20 ___________________________



Вы находитесь на странице вопроса "дан массив из 15 эл. диапазон от 0 до 20 (случ. образом). дано целое число n>0. найти пару соседних элементов суммой равной заданному числу", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.