Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

составить графическую схему алгоритма и написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная

10-11 класс

матрица NxN. Программа должна осуществлять ввод и печать исходной матрицы и возможно, дополнительных данных, произвести необходимые действия и напечатать результаты. Подсчитать общее количество чисел, меньших заданного А, и чисел, больших заданного В среди элементов, находящихся ниже побочной диагонали.

NemuDraya 08 мая 2013 г., 14:47:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dasha2002Lp
08 мая 2013 г., 15:46:50 (10 лет назад)

var a:array[1..100,1..100]of integer;
i,j,c,b,n,k:integer;
begin
readln(n);
readln(c,b);
for i:=1 to n do for j:=1 to n do a[i,j]:=random(9)+1;
for i:=1 to n do begin for j:=1 to n do write(a[i,j],' '); if j=n then writeln; end;
writeln;
for i:=1 to n do
for j:=1 to n do
if (i>n-j+1) or (j<n-i+1) then if (a[i,j]<=c) and (a[i,j]>=b) then inc(k);
writeln(k);
end.

Ответить

Другие вопросы из категории

Читайте также

написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная матрица

NxN. Программа должна осуществлять ввод и печать исходной матрицы и возможно, дополнительных данных, произвести необходимые действия и напечатать результаты.

Найти в каждом четном по номеру столбце матрицы максимальный элемент и вычислить произведение этих элементов.

Построить блок схему алгоритма и написать программу для решения: Даны действительные числа z,y,x.Если сумма двух чисел x y меньше единицы ,то каждое из

заданных трёх чисел заменить полусуммой двух других,в противном случае возвести в квадрат.

Помогите пожалуйста, срочно!!

Написать программу в Турбо Паскале.
Задание:Дан текстовый файл f. Исключить гласные буквы из строк и поместить результат в файл q.

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.



Вы находитесь на странице вопроса "составить графическую схему алгоритма и написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.