Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

найти среднее арифметическое квадратов всех целых чисел от 1 до b (значение b вводится с клавиатуры;b>=100). Поподробнее ,пожалуйста

5-9 класс

Anfisa11 14 сент. 2013 г., 21:01:26 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
АнонимКка
14 сент. 2013 г., 23:23:39 (10 лет назад)

var //это ключевое слово показывает что началось объявление переменных
  b, i:integer;  //тут показали что переменные b, i  типа integer т.е. целые
  Summ:real; {тут показали что переменные Summ  типа real т.е. дробная в ней будет хранится наша сумма}
begin // это слово показывает на начало выполнения программы
  Summ := 0;  //присваиваем начальное значение суммы
  write('b = '); readln(b);  //выводим на экран 'b = ' и считываем b
  for i := 1 to b do {повторяем следующую операцию b раз причем каждый раз i будет увеличиваться на 1 изначально i присваивается 1}
    Summ := Summ + i * i / 2; {присваиваем сумме ее же значение плюс сразу  квадрат переменной i деленный на 2}
  writeln('S = ', Summ); //выводим 'S = ' и за ним сразу значение суммы
  readln; //ожидаем нажатия клавиши enter
end. //конец выполнения программы

+ 0 -
вика779
15 сент. 2013 г., 1:09:46 (10 лет назад)

#include <iostream>

 

using namespace std;

 

int main()

{

 int b;

 cin>>b;

 float a=1;

 for(int i=2;i<=b;i++)

 {

  a = (a*(i-1)+i*i)/i;

 }

 cout<<a<<endl;

 system("PAUSE");

}

-----------------------------------------------------------------------

Ответить

Другие вопросы из категории

Маша Птичкина любит играть в игру Веселый Фермер . И вот как-то раз ее ферма нуждалась в покраске. Маша решила начать с противопожарного щита и покрасить е

го почему-то не в красный , а в оранжевый цвет. Но для этого надо смешать краски желтого (6 частей ) и красного (2 части) цветов. Сколько грамм оранжевой краски может получить Маша, имея в наличии 300г желтой и 600г красной краски

продолжите фразы

1)модель
2)натурная(материальная)модель
3)информационная модель

сколько цветов содержится в палитре?

A)256
B)2
C)30
D)сколько угодно

Читайте также

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

Напечатать "столбиком":

а) все целые числа от 20 до 35;
б) квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b >(или равно)10);
в) третьи степени всех целых чисел от a до 50 ( значение а вводится с клавиатуры; а<(или равно) 50);
г) все целые числа от а до b( значение а и b вводятся с клавиатуры; b>(или равно) а).

Паскаль

5.3 Напечатать "столбиком": а) все целые числа от 20 до 35 б) квадраты всех целых чисел от a до 50 ( значение a вводится с клавиатуры;b>=10) в) третьи степени всех целых чисел от a до 50 ( значение a вводится с клавиатуры;a<=50); г) все целые числа от a до b ( значения a и b вводятся с клавиатуры;b>=a).

1)Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. Программа получает

на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

2)Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вводятся с клавиатуры; a>=200);



Вы находитесь на странице вопроса "найти среднее арифметическое квадратов всех целых чисел от 1 до b (значение b вводится с клавиатуры;b&gt;=100). Поподробнее ,пожалуйста", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.