Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. Pascal (Цикл For)

10-11 класс

Vikaved201438 08 июля 2013 г., 1:59:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mari07
08 июля 2013 г., 4:02:53 (10 лет назад)

Писал уже:
var input, num, nulls, positive, negative, i: integer;
begin
write('Введите кол-во чисел: ');
readln(input);
for i := 1 to input do begin
  write('Введите число номером ', i, ': ');
  readln(num);  if num = 0 then inc(nulls, 1);
  //if num < 0 then inc(negative, 1);
  //if num > 0 then inc(positive, 1);
end;
writeln('Кол-во нулей: ', nulls);
//writeln('Кол-во положительных чисел: ', positive)
//writeln('Кол-во отрицательных чисел: ', negative);
end.

Ответить

Читайте также

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

1)Найдите сумму натуральных нечетных чисел не превышающих n!!!!Это нужно сделать циклом for. 2) Составьте программу,которая производит

суммирование произвольного количества целых чисел вводимых с клавиатуры.Концом последовательности служит ввод отрицательного числа.Программу составьте двумя способами: использую цикл с предусловием и цикл с постусловием

Циклические алгоритмы.СоставьтеЦиклические алгоритмы.Составьте блок- схему для решения следующих задач:

1) Вводятся 100 чисел.Определить сколько среди них положительных и сколько отрицательных.(Числа вводятся в одну переменную в цикле)
2) Алгоритм вычисления суммы квадратов десяти производных чисел, водимых с клавиатуры в процесс выполнения алгоритма
И НАПИШИТЕ ПРОГРАММУ ДЛЯ КАЖДОЙ ЗАДАЧИ



Вы находитесь на странице вопроса "Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. Pascal (Цикл For)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.