Статистика
Всего в нашей базе более 4 327 657 вопросов и 6 445 963 ответов!

Найти остаток от деления целой части значения функции y = ln(x²+ab) на 7 и, в зависимости от его величины, напечатать сообщение об одном из дней недели,

10-11 класс

пронумеровав их от 0 до 6. Значения переменных а, b, x получить случайным образом на произвольном интервале

Sewh 20 июня 2014 г., 5:05:05 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ieu
20 июня 2014 г., 7:16:47 (9 лет назад)

var y,a,b,x:integer;
begin
  a:=-5+random(16); b:=1+random(20); x:=1+random(3);
  y:=ln(sqr(x)+a*b);
  case y mod 7 of
    0:writeln('<Сюда пишешь день недели>');
    1:writeln('<Сюда пишешь день недели>');
    2:writeln('<Сюда пишешь день недели>');
    3:writeln('<Сюда пишешь день недели>');
    4:writeln('<Сюда пишешь день недели>');
    5:writeln('<Сюда пишешь день недели>');
    6:writeln('<Сюда пишешь день недели>');
  end;
  readln
end.

Ответить

Читайте также

Заданы два натуральных числа N и K. Вычислить остаток от деления первого числа на второе. Входные данные: Входной поток содержит два

целых числа N и K (1 <= N <= 10^100, 1 <= K <= 10^9) записанные в двух отдельных строках.

Выходные данные:

В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.txt): 239 16 Пример выходного файла (output.txt): 15

Задача 1. Счастливые билетики по–ярославски

Есть счастливые билетики по–московски, есть счастливые билетики по–питерски, но мало кто слышал про счастливые билетики по–ярославски. В ярославском общественном транспорте номера билетиков состоят из 2N цифр. Билетик называется счастливым, если ярославская сумма первых N цифр равна ярославской сумме последних N цифр. Требуется найти количество счастливых билетиков по–ярославски для заданного N. На первый взгляд, задача простая, но что же такое «ярославская сумма»? Для заданного числа k найдем сумму его цифр, если получившееся число состоит из двух и более цифр, то найдем сумму цифр этого числа и т. д., пока не получим число, состоящее из одной цифры. Такая сумма цифр называется «ярославской суммой цифр». Билетики нумеруются от 00…000 до 99…999.
Вход: файл input.txt, в первой строке которого записано натуральное число N.
Ограничения: 1 ≤ N ≤ 1000
Выход: файл output.txt, содержащий одно число – количество счастливых билетиков по модулю109+7 (т.е. остаток от деления количества счастливых билетиков на 109+7)
Примеры
input.txt output.txt
1 10
6 110888113
Задача 2. Замощение улицы
Новый мэр Эль-Пасо Авраам Гарфилд решил замостить главную улицу города и для этой работы нанял бригаду рабочих во главе с Джорджем Шерманом. Улица представляет собой полосу длиной 4*N метров. Бригада Джорджа будет покрывать её плитками размера 1*2 метра. Плитки можно укладывать как горизонтально, так и вертикально. Шермана интересует, сколькими способами он может замостить главную улицу Эль-Пасо. Так как это число может быть очень большим, то от вас требуется найти число замощений по модулю 109+7 (т.е. найти остаток от деления количества замощений при делении на 109+7).
Вход: файл input.txt, в первой строке которого записано натуральное число N (ширина дороги в Эль-Пасо).
Ограничения: 0 < N < 113
Выход: файл output.txt, содержащий одно число – количество различных способов замостить улицу плитками 1*2 по модулю 109+7 (т.е. остаток от деления количества способов замостить улицу на 109+7).
Примеры
input.txt output.txt
2 5
3 11
7 781
Пояснение к примерам
Улицу длиной 4*2 метра (первый тест из примеров) можно замостить 5 следующими способами:

Задача 3. Упаковка печенья
На вас, как на главном программисте компании по производству печенья, лежит много ответственных заданий. Одно из них – производство и упаковка печенек должна соответствовать самым высоким требованиям Ярославского Консорциума по упаковке печенья.
В любой момент ваша линия производства выпускает новые печеньки, которые хранятся в печенькохранилище, ожидая упаковки. Время от времени поступают запросы с конвейера по упаковке – отправить из печенькохранилища ту печеньку, которую нужно упаковать. Перед поступлением в хранилище, диаметр каждой печеньки измеряется с точностью до 1 нанометра. На упаковку отправляется печенька, являющаяся медианой среди всех печенек. Что такое медиана? Если мы отсортируем печеньки по возрастанию диаметров, то, если печенек нечетное количество c, то на упаковку идёт печенька на позиции (c+1)/2 в отсортированной последовательности. Если же c – четное число, то печенька на c/2+1 в отсортированной последовательности. Если печеньку отправляют на упаковку, то она пропадает со склада. Ваша задача – промоделировать работу системы упаковки печенек.
Вход: файл input.txt, в каждой входной строке которого содержится либо положительное число d, означающее, что в хранилище поступает новая печенька диаметром d нанометров, либо символ '#', означающий запрос с конвейера по упаковке.
Ограничения: 1 ≤ d ≤ 300 000 000; количество строк ввода не более 600 000; также следует считать, что хранилище пусто до тех пор, пока туда не поступит первая печенька.
Выход: файл output.txt, содержащий несколько строк – после каждого запроса на упаковку в отдельную строку выводится диаметр печеньки, которая отправляется на упаковку.
Примеры
input.txt output.txt
1
2
3
4
#
#
#
# 3
2
1
4
1
#
2
#
3
#
4
# 1
2
3
4



Очень прошу помогите с Паскалем!)

1. Напишите программу, вычисляющую площадь прямоугольника. С клавиатуры вводятся два действительных числа – стороны прямоугольника. Необходимо вычислить его площадь и вывести на экран. Вывод должен быть отформатирован следующим образом: под число отводится 10 знаков, а под вещественную часть – 3.
2. С клавиатуры вводятся 3 целых числа. Определить количество положительных чисел в этом наборе.
3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр.
4. С клавиатуры вводится натуральное число n. Узнайте в нем количество цифр.
5. С клавиатуры вводится натуральное число n. Посчитайте сумму S=1+2+…+n.
6. Даны целые положительные числа N и K. Используя только операции сложения и вычитания, найти частное от деления нацело N на K, а также остаток от этого деления.
7. С клавиатуры вводится натуральное число N. За ним последовательно вводятся данные о росте N учащихся класса. Определите средний рост учащихся всего класса. Попробуйте решить эту задачу без использования массивов.
8. Заполнить элементы массива последовательностью чисел: 2, 5, 10, 17, 26, …
9. Вводится число N, а за ним N целых чисел – элементов массива. Найдите количество отрицательных элементов в этом массиве.
10. С клавиатуры вводится число N. Выведите следующую фигуру (N-строк, на последней строке N звездочек). Подсказка: для решения этой задачи примените конструкцию «цикл в цикле».
*
* *
* * *
* * * *

* * * * * * *
11. Массив заполняется целыми числами до «нуля». Замените все положительные числа массив на противоположные им, а отрицательные возведите в квадрат. Выведите изменившийся массив.
12. На вход программе поступает целое число N. Выведите количество делителей N, включая 1 и само число N. Внимание: для решения этой задачи заведите счетчик и не забудьте сначала занести в него значение 0.



Вы находитесь на странице вопроса "Найти остаток от деления целой части значения функции y = ln(x²+ab) на 7 и, в зависимости от его величины, напечатать сообщение об одном из дней недели,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.