Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Построить последовательность чисел Фибоначчи: F=0,1,1,2,3,5,8,13,….n.

10-11 класс

Числа Фибоначчи : последовательность, каждый следующий элемент которой равен сумме 2-х предыдущих., причем известно, что первый член последовательности f0=0, в второй f1 =1.

Llenusy735enusy735 18 нояб. 2014 г., 16:02:20 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Irusya032
18 нояб. 2014 г., 16:39:35 (9 лет назад)

F=0,1,1,2,3,5,8,13,21,34,55,89,144,233,377,610,987,1597,2584,4181,6765,10946,17711...

Ответить

Другие вопросы из категории

Помогите , мне нужны комментарии к этой программе.

Срочно!!
#include <stdlib.h>
#include <conio.h>
#include <stdio.h>
int schet(char *s);
int main() {
char vvod[100];
puts("Vvedite stroku:");
gets(vvod);
printf("%i \n", schet( vvod ));
system("pause");
return 0;
}

int schet(char *s)
{
int dlina, i, sum=0;
for(dlina=0; s[dlina]!='\0'; dlina++);
for(i=0; i if(s[i]>='0' && s[i]<='9')
{
sum=sum+s[i]-'0';
}
return sum;
}

проверьте пожалуйста программу!!!

1. Заполнить массив случайные числами из промежутка [10;20]
2. Найти максимальный и минимальный элементы в этом массиве
3. Обменять первый максимальный и последний минимальный

Читайте также

1. В последовательности чисел подсчитать произведение чисел, кратных 3.

2. В последовательности чисел сравнить, что больше сумма положительных или про-изведение отрицательных.
3. В последовательности чисел определить предпоследнее отрицательное число. (При решении введите дополнительную переменную для хранения предпоследнего отрицательного числа).

Последовательность чисел Фибоначчи образуется так: первый и второй члены последовательности равны единице, каждый следующий член равен сумме двух

предыдущих. (1,1,2,3,5,13...).Дано натуральное число n. n>=3. а)Найти k-й член этой последовательности; б)Для заданного n определить верно ли, что сумма первых n-членов последовательности есть четное число. Помогите, нужно составить программу для решения данных задач!

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.

33. Последовательность чисел

Вводится последовательность целых чисел, заканчивающаяся нулем. Преобразовывать последовательность следующим образом:

1) заменить отрицательные числа в последовательности на их модули и вывести получившуюся последовательность;

2) в полученной последовательности заменить четные числа на максимальное число последовательности, вывести результат;

3) в полученной последовательности вычесть из каждого члена последовательности 2, вывести результат;

4) в полученной последовательности заменить отрицательные на 0, вывести результат.



Пример.

Последовательность: 1 2 3 0

1) 1 2 3

2) 1 3 3

3) –1 1 1

4) 0 1 1



Вы находитесь на странице вопроса "Построить последовательность чисел Фибоначчи: F=0,1,1,2,3,5,8,13,….n.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.