Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу ,которая на вход получает число p.на входе определяет колличество его четных и нечетных делителей

10-11 класс

C++

Monpokimon 18 февр. 2014 г., 7:51:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
1704kxn
18 февр. 2014 г., 8:40:16 (10 лет назад)

#include <iostream> 
int main() {
  int x, c=0, odd=0;
  std::cin >> x;

  for (int i = 1; i<=x; i++) 
    if (!(x%i)) {
      c++;
      if(i%2)
        odd++; 
    }
  std::cout << c - odd << " HE: " << odd << std::endl;
    
  return 0; 
}

Ответить

Другие вопросы из категории

Помогите составить программу на языке PASCAL

В матрице X(5×5) определите произведение положительных элементов
главной диагонали.

В 1975 году джордж лукас приступил к созданию этого фильма. Он собрал команду одних из самых первых в киномире компьютерных фанатов и основал студию

цифровых и визуальных эфектов. Это фильм

А)"Армагедон" Б)"2001: Космическая одисея"

В)"Звёздные воины" Г)"Звёздный путь"

1.
ребят помогите очень надо

Читайте также

помогите коле и напишите программу или алгоритм которое находит все просые числа в диапазоне от m до N ВКлючительно

в задаче требуется написать программу которая по двум заданным числам находила бы в диапазоне между этими числами все простые числам где простое число которое имеет всего лишь два делителя то есть оно делится на единицу и на само себя и больше оно не на что не делиться например -3 7 11 помогите )) олимпиада по инфе )) даю максимум баллов ))

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

Требовалось написать программу, которая вводит с кла­виатуры

координаты точки на плоскости (х,у — действи­тельные числа) и определяет
принадлежность точки за­штрихованной области, включая ее границы. Програм­мист
торопился и написал программу неправильно.



Вы находитесь на странице вопроса "Написать программу ,которая на вход получает число p.на входе определяет колличество его четных и нечетных делителей", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.