Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны длины десяти сторон квадратов. ВЫчислите их площади и периметры. СРОЧНО! В паскале нужно...((

5-9 класс

Arina2lol 26 апр. 2013 г., 11:56:47 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Annenkova38
26 апр. 2013 г., 14:22:11 (11 лет назад)

Если квадратов десять, то:

 

[если честно, лет 7 не кодил на паскале, поэтому могу ошибаться в синтаксисе или каких-то деталях]

задаем 3 массива числовых элементов:

var

S, P, x: array[1..10] of integer; //S - будущие площади, P - периметры, x - стороны квадратов

i: integer; //счетчик для цикла

 

begin

for i := 1 to 10 do

 begin

  Writeln("Введите сторону "+IntToStr(i)+" квадрата:");

  Readln(x[i]);

 end; //ввели стороны, теперь вычисляем площади и периметры:

 

for i := 1 to 10 do

 begin

  S[i] := x[i]*x[i]; //для нахождения площади перемножаем стороны каждого квадрата

  P[i] := x[i]*4; //для нахождения периметра - умножаем сторону квадрата на 4

//и тут же выводим это на экран:

  Writeln("Площадь "+IntToStr(i)+" квадрата равна "+IntToStr(S[i]));

  Writeln("Периметр "+IntToStr(i)+" квадрата равен "+IntToStr(P[i]));

  Writeln;

 end;

 

Readln //это чтоб дождаться нажатия Энтер перед закрытием окошка :)

end;

 

Должно работать.

Ответить

Читайте также

Даны числа a,b,c. Составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон:

равносторонний,равнобедренный или какой либо другой.

Вот ещё одна

Составить программу:Даны а,b,c-целые числа.Если они большн 0-вычислите сумму их квадратов;а если хотя бы одно из них четно-вычислите их сумму и произведение.

Пожалуйста ребят.

Составить программу нахождения площади треугольника по формуле Герона.

Входные данные длины сторон треугольника.
Выходные данные периметр треугольника, площадь треугольника.



Вы находитесь на странице вопроса "Даны длины десяти сторон квадратов. ВЫчислите их площади и периметры. СРОЧНО! В паскале нужно...((", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.