Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Напишите программу,которая получает день,номер месяца и выводит кол-во дней,оставшихся до нового года)))Помогите пожалуйста!!!!!

10-11 класс

Gradylev2014 10 июня 2013 г., 23:50:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Красивая2003
11 июня 2013 г., 1:03:49 (10 лет назад)

var
 d,m,i,all:integer;
begin
 read(d,m);
 all:=0;
 for i:=12 downto (m+1) do
 begin
  if i=12 then
   all:=all+31;
  if i=11 then
   all:=all+30;
  if i=10 then
   all:=all+31;
  if i=9 then
   all:=all+30;
  if i=8 then
   all:=all+31;
  if i=7 then
   all:=all+31;
  if i=6 then
   all:=all+30;
  if i=5 then
   all:=all+31;
  if i=4 then
   all:=all+30;
  if i=3 then
   all:=all+31;
  if i=2 then
   all:=all+28;
  if i=1 then
   all:=all+31;
 end;
 if i=12 then
   all:=all+31-d;
  if i=11 then
   all:=all+30-d;
  if i=10 then
   all:=all+31-d;
  if i=9 then
   all:=all+30-d;
  if i=8 then
   all:=all+31-d;
  if i=7 then
   all:=all+31-d;
  if i=6 then
   all:=all+30-d;
  if i=5 then
   all:=all+31-d;
  if i=4 then
   all:=all+30-d;
  if i=3 then
   all:=all+31-d;
  if i=2 then
   all:=all+28-d;
  if i=1 then
   all:=all+31-d;
 writeln(all);
end.

+ 0 -
Anymus
11 июня 2013 г., 2:30:05 (10 лет назад)

Комментарий удален

+ 0 -
вова234
11 июня 2013 г., 4:02:33 (10 лет назад)

В паскале,английскими буквами)

+ 0 -
Fatkulin2003
11 июня 2013 г., 5:25:07 (10 лет назад)

Комментарий удален

+ 0 -
Capitan09
11 июня 2013 г., 7:19:48 (10 лет назад)

Комментарий удален

+ 0 -
Solnyshko2004
11 июня 2013 г., 8:29:07 (10 лет назад)

Паскаль ABC,free

Ответить

Другие вопросы из категории

Для ремонта школы использовали белую, синюю и коричневую краски. Израсходовали одинаковое количество банок белой и синей краски. Сообщение о том, что

закончилась банка белой краски, несет 2 бита информации. Синей краски израсходовали 8 банок. Сколько банок коричневой краски израсходовали на ремонт школы?

Читайте также

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.

Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию.

Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

1)Проверка условия и ветвление в алгоритме.Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран:

а)удвоенное значение числа,если число положительное; б)абсолютное значение числа,если число отрицательное.
2)Напишите программу которая анализирует введенное с клавиатуры число на четность и сообщает о результате.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива



Вы находитесь на странице вопроса "Напишите программу,которая получает день,номер месяца и выводит кол-во дней,оставшихся до нового года)))Помогите пожалуйста!!!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.