Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

написать программу нахождения произведения чисел кратным четырём и находящихся в промежутке от 5 до 39

1-4 класс

Maximus16rus 19 нояб. 2015 г., 12:27:22 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Redfoo
19 нояб. 2015 г., 13:36:11 (8 лет назад)

23781703680
-----------------------------
product=1
(5..39).each {|i| product*=i if i%4==0}
p product
---------------------

var i :integer;
    p : real;
begin
    p := 1;
    for i := 5 to 39 do
        if i mod 4 = 0 then
            p:=p*i;

    writeln(p);
end.




+ 0 -
Lililovexzm
19 нояб. 2015 г., 15:38:27 (8 лет назад)

const  n = 10;
var  a :array [1..n] of integer;  i, p :integer;
begin
  for i:= 1 to n do     readln(a[i]);  p:= 1;  for i:= 1 to n do    if (a[i] > 5) and (a[i] < 39) and (a[i] mod 4 = 0) then       p:= p * a[i];  writeln(p);
end.

Ответить

Другие вопросы из категории

реши 5 примеров:1).7+19+11+13=50 2.)6+16+5=27 3)19-3-9=7 4)19-7-3-2=7 5)2+5+4+6=17 есть чем-то похожие примеры.запиши номера примеров,которые можно

обЪединить в одну группу по какому-либо признаку.признак укажи в скобках.



Вы находитесь на странице вопроса "написать программу нахождения произведения чисел кратным четырём и находящихся в промежутке от 5 до 39", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.