Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

1) такое составной оператор? В каких случаях составной оператор используется в операторе ветвления? 2) составьте программу сортировки по

5-9 класс

возрастанию значений трех переменных: А Б С в системе паскаль

Lanalyga2001 01 дек. 2014 г., 6:19:32 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vladislavfilat
01 дек. 2014 г., 8:38:04 (9 лет назад)

1) Составной оператор — конструкция языка программирования, состоящая из нескольких команд (операторов) языка программирования, но участвующая в программе в качестве единого оператора.

+ 0 -
Жанна5555555555
01 дек. 2014 г., 9:09:52 (9 лет назад)

 

uses
crt;
var
a,b,c,e,i:integer;
d:array [1..3] of integer;
begin
write('a=');
readln(a);
write('b=');
readln(b);
write('c=');
readln(c);
d[1]:=a;
d[2]:=b;
d[3]:=c;
for i:=1 to 2 do
if d[i]>d[i+1] then
begin
e:=d[i];
d[i]:=d[i+1];
d[i+1]:=e;
end;
for i:=1 to 3 do
writeln(d[i]);
end.

 

 

ну или вот попроще

program sort;
uses crt;
var t,a,b,c: integer;
begin
Write('Vvedite a,b,c: ');
readln(a,b,c);
repeat
repeat
if a>b then begin
t:=a;
a:=b;
b:=t;
end;
if b>c then begin
t:=b;
b:=c;
c:=t;
end;
if a>c then begin
t:=b;
c:=a;
a:=t;
end;
until ((a<b) and (b<c));
writeln('Результат: ',a,' ',b,' ',c);
readkey;
end.

 

 

Ответить

Другие вопросы из категории

Кот Матроскин и пёс Шарик нашли клад, который состоял из 5 одинаковых монт. В коробке, в которой лежали монеты, друзья обнаружили записку: "При помощи

чашечных весов без гирь найдите среди этих 5 монет одну золотую и купите почтальону Печкину велосипед. Сделайте это при помощи двух взвешиваний. Золотыя монета более тяжёлая". Дядя Фёдор помог своим друзьям справится с этим заданием. Как он действовал? Впишите действия Дяди Фёдора в блок схему.

Помогите, добрые люди.

Сообщение занимает 3 страницы на странице 4 строки в строке 2 символа. Определите информационный объём сообщения,если при составлении этого сообщения использовали 128 символьный алфавит.

помогите пожалуйста блок схему:

1)сделал дело,гуляй смело
2)где песня поётся,там весело живётся.

Читайте также

В каком случае верно равенство 8+7=3

1.Если это часы на циферблате
2.это 16-ичная систем счисления
3.Такое,невозможно,ни при каких условиях
4.Если это римские числа

В каком случае верно равенство: 8+7=3?

а) Если это часы на циферблате
б) Если это 16-ичная система счисления
в) Такое невозможно, ни при каких условиях
г) Если это римские числа.

Даны числа a,b,c. Составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон:

равносторонний,равнобедренный или какой либо другой.

Вот ещё одна

Составить программу:Даны а,b,c-целые числа.Если они большн 0-вычислите сумму их квадратов;а если хотя бы одно из них четно-вычислите их сумму и произведение.

Пожалуйста ребят.



Вы находитесь на странице вопроса "1) такое составной оператор? В каких случаях составной оператор используется в операторе ветвления? 2) составьте программу сортировки по", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.