Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Методом половинного деления вычислить на ЭВМ корень уравнения вида f (x) = 0, расположенный на интервале [a, b] с заданной погрешностью.

10-11 класс

Определить число итераций, необходимое для нахождения корня.
3sin√x+0,35x-3,8=0 [2;3] 10^(-3)
НУЖНО ПРЯМ ПРОГРАММУ(

Manya060198 16 февр. 2015 г., 10:32:54 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cannomarion
16 февр. 2015 г., 11:05:48 (9 лет назад)

function f(x: real): real;
begin
  f := 3 * sin(sqrt(x)) + 0.35 * x - 3.8
end;

var
  n: integer;
  a, b, c, fc, eps: real;

begin
  writeln('Введите границы интервала (a,b) и точность решения: ');
  readln(a, b, eps);
  n := 0;
  repeat
    c := (a + b) / 2;
    fc := f(c);
    if sign(fc) = sign(f(b)) then b := c
    else a := c;
    n := n + 1;
  until abs(a - b) <= eps;
  writeln('Найден корень уравнения х=', c, ' за ', n, ' итераций')
end.

Тестовое решение:

Введите границы интервала (a,b) и точность решения:
2 3 0.001
Найден корень уравнения х=2.2978515625 за 10 итераций


+ 0 -
I9166590153
16 февр. 2015 г., 13:58:45 (9 лет назад)

Комментарий удален

+ 0 -
Magomadovaaluza
16 февр. 2015 г., 15:06:50 (9 лет назад)

паскаль

+ 0 -
Angelina150302
16 февр. 2015 г., 16:52:00 (9 лет назад)

нужно написание программы

Ответить

Читайте также

Методом (половинного деления или итерации)(нужно выбрать правильный) найти корень уравнения (x-3)/(x^2+2)=0 расположенный на отрезке [-1;4] с

абсолютной погрешностью 10^-4

программа паскаль

и еще нужна блок схема

Заданы два натуральных числа N и K. Вычислить остаток от деления первого числа на второе. Входные данные: Входной поток содержит два

целых числа N и K (1 <= N <= 10^100, 1 <= K <= 10^9) записанные в двух отдельных строках.

Выходные данные:

В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.txt): 239 16 Пример выходного файла (output.txt): 15

Задача 1 Составить программу При поступлении в вуз абитуриенты , получившие "двойку" на первом экзамене , ко второму не допускаются . В

массиве A[n] записаны оценки экзаменующихся , полученные на первом экзамене . Подсчитать , сколько человек не допущено ко второму экзамену .

Задача 2

В одномерном массиве , состоящем из n вещественных элементов , вычислить ;

1) минимальный элемент массива;

2)сумму элементов массива , расположенных между первым и последним положительными элементами .

Преобразовать массив таким образом , чтобы сначала располагать все элементы , равные нулю, а потом-все остальные .

сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен удвоенному числу, введенному с клавиатуры;
2-й равен квадрату предыдущего индекса;
3-й равен остатку от деления индекса на 2



Вы находитесь на странице вопроса "Методом половинного деления вычислить на ЭВМ корень уравнения вида f (x) = 0, расположенный на интервале [a, b] с заданной погрешностью.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.