Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дана непустая последовательность различных натуральных чисел, за каторой следует 0. Определить порядковый номер 0

5-9 класс

Ekaterinaydikin 26 дек. 2014 г., 7:10:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
TANER2003
26 дек. 2014 г., 8:17:30 (9 лет назад)

var

  c, tmp : integer;

begin

  c := 0;

  tmp := 1;

  repeat

    read (tmp);

    inc (c);

  until tmp = 0;

  writeln (c);

end.

+ 0 -
Svitlanamar
26 дек. 2014 г., 11:00:48 (9 лет назад)

var i:integer;

c:char;
begin
while c<>'0' do begin
readln(c);
inc(i);
end;
writeln(i);
end.

Ответить

Читайте также

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

задача 1. Дано натуральное число n. Напишите программу выводящую на экран последовательность натуральных чисел от 1 до n. задача 2. Даны

натуральные числа A , B, где B>A. Напишите программу последовательность натуральных чисел от A до B, включающая A и B.

Пожалуйста помогите !!!!!!!!

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число. Программа получает на вход целые числа,

количество введенных данных неизвестно, последовательность чисел заканчивается числом 0. На Паскале

Дана непустая последовательность целых чисел, оканчивающаяся нулем

(0 является признаком окончания последовательности и в последовательность не входит).
Найти и напечатать:
1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Если таких чисел нет, то напечатать «Таких чисел нет»
2. Количество четных чисел

Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел.Программа получает на вхо

д количество чисел в последовательности, а затем сами числа.Количество чисел не превышает 1000. Введённые числа не превышают 30 000.Программа должна вывести одно число – количество двузначных чисел в заданной последовательности натуральных чисел.



Вы находитесь на странице вопроса "Дана непустая последовательность различных натуральных чисел, за каторой следует 0. Определить порядковый номер 0", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.