Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу, которая печатает True или False в зависимости от того, выполняются или нет

10-11 класс

заданные условия:

MakShagun 31 марта 2014 г., 19:03:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sveta198437
31 марта 2014 г., 19:54:23 (10 лет назад)

var b: 100..999;

      s: word;

      x, y, m, n: integer;

begin

  writeln('Введите трехзначное число');

  readln(b);

  s:=(b mod 10)+((b mod 100)div 10)+(b div 100); //сумма цифр трехзначного числа

  if sqr(b)=sqr(s)*s then writeln('True')

  else writeln('False');

  writeln('Введите координаты х и у');

  readln(x, y);

  writeln('Введите m и n');

  readln(m, n);

  if (x>m)and(x<n) then writeln('True')

  else writeln('False');

end.

  

     

Ответить

Другие вопросы из категории

запишите заголовки цикла for для изменения параметра из диапазонов от -10 до +10______________________ от 100 до 1

_______________________

от 15 до 25 ________________________

от -10 до -20 ___________________________

Было выпущено 2000 лоторейных билетов пронумерованных от 1 до 2000. При продаже билета в специальное устройство заносится его номера использованием

минимально возможного количества бит, одинакового для каждого билета. Какой информационный объем сообщения записанного устройством после того как было продано 40 билетов? 1) 50 байт 2) 55 байт 3) 440 байт 4) 10 000 бит

Читайте также

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

Изначально, задача была такая: На вход программы подается натуральное число. Требуется написать программу, которая определяет составное или простое число

на входе и выводит сумму его цифр.

Я написал первую часть программы (без вывода суммы цифр) :

program sg3;

uses crt;

var i,a,k: integer;

begin

clrscr;

write('Введите число: ');

readln(a);

k:=0;

for i:=2 to a div 2 do

if a mod i =0 then k:=k+1;

if k=0 then write('Простое')

else writeln('Составное');

readln;

end.

Допишите пожалуйста код, который бы выводил сумму цифр,Паскаль

помогите коле и напишите программу или алгоритм которое находит все просые числа в диапазоне от m до N ВКлючительно

в задаче требуется написать программу которая по двум заданным числам находила бы в диапазоне между этими числами все простые числам где простое число которое имеет всего лишь два делителя то есть оно делится на единицу и на само себя и больше оно не на что не делиться например -3 7 11 помогите )) олимпиада по инфе )) даю максимум баллов ))

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.



Вы находитесь на странице вопроса "Написать программу, которая печатает True или False в зависимости от того, выполняются или нет", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.