Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано целое число k (1<=k<=180) и последовательность цифр 10111213...9899, в которой выписаны подряд подряд все двузначные числа. Определить

10-11 класс

двузначное число, образованное парой цифр, в которую входит k-я цифра;
Примечание: величины строкового типа не использовать.

p.s объясните само задание, пожалуйста. Решение есть на яндексе.

Hitman86rus 12 сент. 2014 г., 11:58:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cem23
12 сент. 2014 г., 12:38:00 (9 лет назад)

 Расписал в // что, да как) Если не понятно, то пиши. 

+ 0 -
Zinakamenskih
12 сент. 2014 г., 15:21:45 (9 лет назад)

Да, сейчас напишу решение.

+ 0 -
Bozka
12 сент. 2014 г., 15:56:46 (9 лет назад)

П.с. чувак с майла вообще фигню сморозил..

+ 0 -
Irinanovoselts
12 сент. 2014 г., 18:13:27 (9 лет назад)

реализовать надо кстати в си

+ 0 -
Beoguzov
12 сент. 2014 г., 18:45:27 (9 лет назад)

Обидно... П.с. могу только паскаль. Думаю не составит труда конвертировать код?

+ 0 -
саша19
12 сент. 2014 г., 20:15:54 (9 лет назад)

код не вопрос. понять бы задание)

Ответить

Другие вопросы из категории

Вычислить сумму Z = 1 + 2 + 3 + ... . Вычисления прекратить, когда значение Z превысит заданное значение A. Решить

при помощи:

1.Операторов цикла.(i:=N1 to N2 do "оператор")

2.Цикла с предусловием.(While)

Здравствуйте! 1) Подскажите пожалуйста, как перевести 973,375(10) в двоичную систему? Или можете расписать как переводить числа с запятой в двоич

ную?

2) сложить, 1011101001,1 + 1110111,01, или скажите как складывать числа с запятой, не понимаю, куда дописывать недостающие нули после запятой

Дано натуральное число: определить а) количество цифр в нем б)сумму его цифр в)произведение его цифр г)среднее арифметическое его цифр

д)сумму квадратов его цифр е)сумму кубов его цифр ж)его первую цифру з)сумму его первой и последней цифр

Разработать словесный и графический алгоритм для двух функций при х принадлежит [-2,2] с шагом 0,2 R = K1 * Z1^2 - B * Z2 / ( K - Z3 ) ; В изменяется

от 10 до 1 с шагом -1 z1,z2,z3,k,K1-произвольно

1) В массиве А1, ... , Аn найти количество единиц, стоящих на чётных местах.

2) В массиве M1, ... , Mn вычислить сумму элементов до последнего нулевого

Читайте также

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

Заданы два натуральных числа N и K. Вычислить остаток от деления первого числа на второе. Входные данные: Входной поток содержит два

целых числа N и K (1 <= N <= 10^100, 1 <= K <= 10^9) записанные в двух отдельных строках.

Выходные данные:

В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.txt): 239 16 Пример выходного файла (output.txt): 15

Ввести с клавиатуры три числа (x,y,z). Если x<y<z, то все числа удвоить.

Если z<y<x, то максимальное число возвести в квадрат. Если числа не
удовлетворяют ни одному из условий – обнулить их.

Тест по паскалю!!!

100. Назовите все отличия функций от процедур?
а) функция передает в точку вызова скалярное значение, а процедура - нет
б) имя процедуры может состоять из трех символов, а функция - нет
в) процедура имеет структуру, повторяющую структуру программы, а в функции отсутствует блок описания переменных
г) имя функции может входить в выражении как операнд

101. С помощью каких параметров происходит передача данных из главной программы в подпрограмму?
а) фактических
б) формальных
в) неформальных
г) подпрограммных

102. Выберите неправильную форму записи оператора цикла
а) WHILE I<5 DO I:=I+1
б) WHILE I<5 DO BEGIN I:=I+1; WRITELN(I); END
в) WHILE I<5 TO BEGIN I:=I+1; WRITELN(I); END

103. Какое выражение обеспечивает генерирование случайных чисел в диапазоне [4,10[
а) 4+RANDOM(6)
б) 6+RANDOM(4)
в) RANDOM(4,6)

104. что означает FV в команде read(FV, x1, x2,..., xn) в Паскале ?
а) формат ввода
б) переменную, связанную с файлом, откуда берется информация
в) фиксированную величину
г) первую переменную величину для ввода информации

105. Каким окажется результат выполнения следующего фрагмента кода X:= 5; Y:= X+1; Writeln('Х=',X, Y=',Y);?
а) X=6 Y=5
б) X=5 Y=5
в) X=5 Y=6

106. Какое значение примет переменная Х после выполнения команды X:=SQR(4)/2*2?
а) 4
б) 2
в) 16

107. Каким окажется результат выполнения следующего фрагмента кода: X:= 5; Y:= 8; Т:= Х; X:=Y; Y:= T; Writeln('Х=', X, Y=',Y);?
а) X=5 Y=8
б) X=8 Y=5
в) X=5 Y=5

108. Логическое выражение
(N Mod 10 Mod 2) Or (N Div 10 Mod 10 Mod 2 = 0) Or (N Div 100 Mod 2 = 0)
должно принимать значение TRUE тогда и только тогда, когда истинно высказывание
а) в трёхзначном натуральном числе все цифры чётные
б) в трёхзначном натуральном числе одна чётная цифра
в) в трёхзначном натуральном числе две чётных цифры
г) в трёхзначном натуральном числе хотя бы одна чётная цифра

109. Цикл в фрагменте программы P := 4; Repeat P := P * 0.1 Until P < 0.0001; будет исполнен?
а) 0 раз
б) 1 раз
в) 4 раза
г) 5 раз

110. Значение R после выполнения операции логического присваивания
R := Not (A Or B Or (X > 2) And (Y < 0))
при A = False, B = False, X = 3, Y = 2 будет равно
а) -1
б) False
в) True
г) 0

111. Значения переменных a и b после выполнения следующих действий
a := 15 Div (16 Mod 7); b := 34 Mod a * 5 - 29 Mod 5 * 2;
будут равны
а) a = 1, b = 160
б) a = 1, b = 4
в) a = 7, b = 25
г) a = 7, b = 22

112. Во фрагмент алгоритма, печатающий все двузначные числа, в записи которых есть цифра N или сумма цифр которых равна самим числам, нужно вписать логическое выражение
а) (P1 = N) Or (P2 = N) And (S = K)
б) (P1 = N) Or (P2 = N) Or (S = K)
в) (P1 = N) And (P2 = N) Or (S = K)
г) ((P1 = N) Or (P2 = N)) And (S = K)

113. Тело цикла в программе a := 1; b := 1; While a + b < 8 Do begin a := a + 1; b := b + 2 end;
выполнится?
а) 1 раз
б) 2 раза
в) 3 раза
г) бесконечное число раз

114. Задана строка St (см Фрагмент алгоритма)
а) определяет количество цифр в строке
б) подсчитывает количество нулей в строке
в) определяет сумму номеров позиций в строке, где стоят цифры
г) подсчитывает сумму цифр в строке;

115. Задан двумерный массив X[1..n, 1..m]. Процедура
а) к элементам столбцов в первой половине матрицы прибавляет элементы первого столбца соответствующей строки
б) добавляет к матрице еще M столбцов с элементами, равными соответствующим элементам первого столбца
в) к элементам четных столбцов прибавляет элементы первого столбца соответствующей строки
г) к элементам четных строк прибавляет элементы первой строки соответствующего столбца;

116. Задан двумерный массив X[1..n, 1..m]. Функция возвращает значение
а) True, если все элементы массива ненулевые
б) True, если в массиве есть элемент, равный нулю
в) False, если в массиве есть элемент, равный нулю
г) Not t;

117. Значение R после выполнения операции логического присваивания
R := Not (A Or B Or (X > 2) And (Y < 0))
при A = False, B = False, X = 3, Y = 2 будет равно
а) 1
б) False
в) True
г) 0

118. В каком фрагменте программы подсчитывается сумма элементов квадратной матрицы, расположенных выше главной диагонали?

а) For i:= 1 to n do
For j:= 1 to n do
If i<=j then
S:=s+a[I,j];

б) For i:= 1 to n do
For j:= i+1 to n do
S:=s+a[I,j];

в) For i:= 1 to n do
For j:= 1 to n do
If i>j then
S:=s+a[I,j];




Вы находитесь на странице вопроса "Дано целое число k (1&lt;=k&lt;=180) и последовательность цифр 10111213...9899, в которой выписаны подряд подряд все двузначные числа. Определить", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.