Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В строке символов ,слова разделить пробелом ,если в ней встречается слово "воронеж" то заменить маленькую в на

10-11 класс

большую В

N2284 17 янв. 2014 г., 6:09:13 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Henkok
17 янв. 2014 г., 7:59:57 (10 лет назад)

var s:string; i:integer;

begin

read(s);

for i:=1 to length(s);

if s[i]='в' and s[i+1]='о' and s[i+2]='р'  and s[i+3]='о' and s[i+4]='н' and s[i+5]='е' and s[i+6]='ж' then s[i]:='В';

writeln(s);

end.

Ответить

Читайте также

Дана стока состоящая из латинских букв,в которой слова разделены пробелами(одним или несколькими).Напечатать те строки,которые отличны от последнего слова

и удовлетворяют след. свойству:
- слово совпадает с начальным отрезком латинского алфавита ('a','ab','abc' и т.д.)

P.s. Только решить её надо не использую строки.Вместо них array of char...
Пример ввода:
writeln('Введите предложение, символ конца - точка');
i := 0;
repeat
inc(i);
read(a[i])
until (a[i] = '.')or(i = n);

Заранее огромное спасибо.

Дана строка русского текста до 60 символов.Слова разделены пробелами.Заменить встречающиеся в строке слова то на слово это.Напечатать исходную и

полученную строки.Напишите,пожалуйста,программу.Составить программу в паскале.

Как составить программу автоматического переноса слов? задается максимальная длина строки и предполагается, что слова разделяются пробелом. В этом

случае надо следить за текущей позицией в строке и при вводе очередного "слова" контролировать, чтобы его длина плюс текущая позиция не превысили длины строки. в QBasic

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!



Вы находитесь на странице вопроса "В строке символов ,слова разделить пробелом ,если в ней встречается слово "воронеж" то заменить маленькую в на", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.