Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Напишите программу, которая вводила бы целые числа и суммировала их до тех пор, пока пользователь не ввел число 0

10-11 класс

Akosachjov 01 мая 2013 г., 18:34:01 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
KISUNAA
01 мая 2013 г., 21:06:27 (11 лет назад)

Var
a,s:integer;
begin
  s:=0;
  repeat
  readln(a);
  s:=s+a;
  until a=0;
  writeln('Сумма чисел: ',s);
end

Ответить

Другие вопросы из категории

Составить алгоритм, который определяет сумму четных

чисел из трех введенных a,b,c. Если таких нет, то вывести
сообщение об этом. (Можно с объяснением пожалуйста)

Когда изобрели 1-ый магнттофон
1.

Читайте также

1)Проверка условия и ветвление в алгоритме.Напишите программу которая анализирует введённое с клавиатуры число и выдает на экран:

а)удвоенное значение числа,если число положительное; б)абсолютное значение числа,если число отрицательное.
2)Напишите программу которая анализирует введенное с клавиатуры число на четность и сообщает о результате.

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.



Вы находитесь на странице вопроса "Напишите программу, которая вводила бы целые числа и суммировала их до тех пор, пока пользователь не ввел число 0", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.