Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Что будет напечатано в результате выполнения следующего фрагмента: var a,b : integer; begin b=0 a=96 while

5-9 класс

a<>3 do

begin

a=a div 2

b=b+a

end

write(b)

end.

Lizytka 15 дек. 2014 г., 9:10:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nikitaw99
15 дек. 2014 г., 11:54:59 (9 лет назад)

Программа выдаст число "93".

В коде и вправду много синтаксических ошибок. Вот верный код:

var a,b : integer;
begin
b:=0;
a:=96;
while a<>3 do
begin
a:=a div 2;
b:=b+a;
end;
write(b);
end.

+ 0 -
ApTeM1702
15 дек. 2014 г., 12:53:22 (9 лет назад)

выйдет только число 93, причем только если сделать правилбьно все знаки присваивания и точки запятой в конце строк.

 

это какая-то неправильная программа у тебя

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПОЖАЛУЙСТА!!! Фирма "Электронные приборы" выпустила автоматизированную ванну "Банный комплекс-XXI", на пульте управления такие

кнопки:

"Долить 1л"

"Долить 2 л"

"Долить 3л"

"Долить 4л"

"Долить 5л"

"Слить 1л"

"Слить 2л"

"Слить 3л"

"Слить 4л"

"Слить 5л"

"Слить всю воду"

Однако в результате ошибки фирмы все кнопки, кроме "Долить 5л" и "Слить 3л", не работают. Напишите программу, позволяющую долить в ванну следующие количества воды:

4 Литра...

Какие из ниже приведенных записей являются алгоритмами(можно выбрать несколько или совсем ничего не выбирать)?Ответ:Пойди туда, не знаю куда,

принеси то, не знаю что.Возьми с полки пирожок, сдуй с него пыль и съешь.Чем дальше в лес, тем больше дров.a+b

Кто знает, решите пожалуйста

Читайте также

Определите, что будет напечатано в результате выполнения следующего алгоритма:

Var s,k: integer;
begin
s:= 100
k:=7
repeat
s:= s-k
k:=k+1
Until k>10
writeln( s+k)
end.
Пожалуйста объясните как вывести отсюда результат

В таблице Dat хранятся оценки (по десятибалльной шкале) студента по программированию за 8 прошедших с начала учебы семестров (Dat[1] -оценка за первый

семестр, Dat[2] - оценка за второй семестр и т.д.). Определите что будет напечатано в результате выполнения следующего алгоритма:

Var k,m, term: integer;

Dat: array[1..8] of integer;

begin

Dat[1]:= 7 ; Dat[2]:= 7 ; Dat[3]:=6 ; Dat[4]:= 8 ;

Dat[5]:=4 ; Dat[6]:= 5; Dat[7]:= 4; Dat[8]:= 7;

term:=1; m:=Dat[1];

for k:=2 to 8 do

begin if Dat[k] < m then

begin m:=Dat[k]; term:=k

end end

write (term); end.

Определите, что будет напечатано в результате выполнения следующего алгоритма var k,m,i: integer; mas:array[1..10] of integer; begin

mas[1]:=12;

mas[2]:=43;

mas[3]:=48;

mas[4]:=56;

mas[5]:=76;

mas[6]:=73;

mas[7]:=36;

mas[8]:=96;

mas[9]:=69;

mas[10]:=25;

k:=0;

m1:=mas[1] div 10 - mas[1] mod 10;

for i:=2 to 10 do begin

m2:=mas[i] div 10 - mas[i] mod 10;

if m1 > m2 then begin

m1:=m2; k:=i;

end;

end;

write(k);

end.

Помогите, пожалуйста, выполнит задания, связанные с Turbo Pascal: 1) Определить, что будет напечатано

в результате работы следующего фрагмента программы:

var k,s:integer;

begin

s:=0;

k:=1;

while k<11 do begin

s:=s+k;

k:=K+1;

end;

write(s);

end.

1.1 Запишите этот же фрагмент с помощью оператора Repeat...until

2) Значения двух массивов A[1..100] и B[1..100] задаются с помощью следующего фрагмента программы:

for n:=1 to 100 do

A[n]:=n-10;

for n:=1 to 100 do

B[n]:=A[n]*n;

Сколько элементов массива B будут иметь положительные значения?

а)10 б)50 в)90 г)100



Вы находитесь на странице вопроса "Что будет напечатано в результате выполнения следующего фрагмента: var a,b : integer; begin b=0 a=96 while", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.