Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

VBA - пожалуйста

10-11 класс

Написать
процедуру, в которой формируется массив Name из 8 фамилий сотрудников
(считываются с ячеек столбца A рабочего листа), затем организуется ввод
с клавиатуры возраста каждого сотрудника в массив Age, затем, значения
возраста выводятся на рабочий лист в соответствующие ячейки столбца B.

Цветочек29 22 июля 2013 г., 17:05:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Spdiana06
22 июля 2013 г., 17:46:38 (10 лет назад)

Sub aaa()
Dim n As Integer, i As Integer
Dim mName() As String, Age() As String
    i = 0
    While Len(Cells(i + 1, 1)) > 0
        i = i + 1
    Wend
    n = i
    ReDim mName(1 To n), Age(1 To n)
    For i = 1 To n
        mName(i) = Cells(i, 1).Value
        Age(i) = InputBox("Ведите возраст сотрудника " + mName(i))
        Cells(i, 2).Value = Age(i)
    Next i
End Sub
   

Ответить

Другие вопросы из категории

1)Определите длительность звукового файла, который уместится на дискете 3,5"

при высоком качестве звука (16 бит, 48 кГц).Учтите, что для хранения данных на такой дискете выделяется 2847 секторов объёмом 512 байт каждый (ход решения)

2)Вычислить информационный объём текстового документа в Мбайт( с точность до сотых)
и узнать,сколько дискет 3,5 дюйма объёмом 1,44 мб понадобится для переноса англо-русского словаря,который содержит 604 страницы ( 89 символов в строке, 66 строк на странице) (ход решения)

1. Сформировать внутреннюю и внешнюю файл-функцию.

//Задан одномерный массив,вывести на печать все элементы, которые равны первому.
const n=5;
Var A:array[1..n] of integer;
i:integer;
Begin
// Формируем и выводим массив
Writeln(' Массив: ');
For i:=1 to n do
Begin
A[i]:=Random(10);
Write(A[i]:2);
end;
Writeln();

// Находим элементы, которые равны первому.
Writeln(' Первому элементу равны:');
For i:=1 to n do
begin
If (A[1]=A[i]) then
Write(A[i]:2)
end;
end.

На Паскале решить задачу. Задан целочисленный вектор Х размерностью n, представляющий последовательность целых чисел. Определить число инверсий

в этой последовательности.

рекомендации: инверсией считать пару элементов, в которой большее число находится перед меньшим (хi>xj, если i>j)

Читайте также

Помогите написать программу на VBA пожалуйста

Дан целочисленный массив. Напечатать те его элементы, индексы которых являются степенями двойки (1,2,4,6,8 и т. д.)

Пожалуйста помогите найти текст про садовые цветы(растения)

срочно пожалуйста!!!!!!1
срочно!

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.



Вы находитесь на странице вопроса "VBA - пожалуйста", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.