Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Срочно, помогите ! Дан массив целых чисел, состоящий из 20 элементов, заполненный случайным образом числами из промежутка от –50 до 50. Посчитать

5-9 класс

кол-во похожих элементов подсчитать сумму четных элементо

Blumiskay 11 дек. 2016 г., 11:11:33 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
АльчонокАлененок
11 дек. 2016 г., 12:52:42 (7 лет назад)

var a:array[1..20] of integer;
i,j,k,l,s:integer;
begin
for i:=1 to 20 do begin
randomize;
a[i]:=random(101)-50;
write(a[i],' ');
end;
k:=0;
l:=0;
for i:=1 to 20 do begin
if l<k then l:=k;
k:=0;
for j:=1 to 20 do
if a[i]=a[j] then k:=k+1;
end;
Writeln;
writeln(l);
for i:=1 to 20 do
if i mod 2 = 0 then s:=s+a[i];
writeln(s);
end.

 

Выводит массив из рандомных 20 чисел между -50 и 50

допустим

0 1 -2 1 2 3 5 4 5 8 9 10 14 -14 8 -11 10 45 6 1

 

Затем выводит макс. кол-во похожих

0 1 -2 1 2 3 5 4 5 8 9 10 14 -14 8 -11 10 45 6 1

3

 

И теперь сумму четных элементов

0 1 -2 1 2 3 5 4 5 8 9 10 14 -14 8 -11 10 45 6 1

1+1+3+4+8+10-14-11+45+1=48

 

Ответить

Другие вопросы из категории

помогите , пожалуйста, с решением, в понедельник экзамен!!! Напишите программу для решения следующей задачи. Камера наблюдения

регистрирует в автоматическом режиме скорость проезжающих мимо нее автомобилей, округляя значения скорости до целых чисел. Необходимо определить максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была меньше 30 км/ч, выведи YES, иначе выведите NO. Программа получает на вход число проехавших автомобилей N ( 1 ≤ N ≤ 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300. Программа должна сначала вывести максимальную скорость, затем YES или NO.

Пример работы программы:

Входные данные Выходные данные

4 74

74 NO

69

63

66

Читайте также

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

СРОЧНО ПОЖАЛУЙСТА ЧЕРЕЗ ПРОГРАММУ ПАСКАЛЬ

1).найти все четырехзначные числа,делящиеся на 27.
2).дан массив целых чисел,состоящий из 20 элементов.Заполнить его случайными числами и найти количество элементов массива. значения которых больше заданного числа и кратны 5.

СРОЧНО ПОЖАЛУЙСТА ЧЕРЕЗ ПРОГРАММУ ПАСКАЛЬ

1).найти все симметричные четырехзначные числа,делящиеся на 27.
2).дан массив целых чисел,состоящий из 20 элементов.Заполнить его случайными числами и найти количество элементов массива. значения которых больше заданного числа и кратны 5.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.



Вы находитесь на странице вопроса "Срочно, помогите ! Дан массив целых чисел, состоящий из 20 элементов, заполненный случайным образом числами из промежутка от –50 до 50. Посчитать", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.