Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

С клавиатуры вводится список. Найти сумму максимального и минимального элементов списка. Выведите на экран полученный список. (С++)

5-9 класс

Nikpetrusha73 06 дек. 2014 г., 10:29:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ЛилияСеливанова
06 дек. 2014 г., 11:48:17 (9 лет назад)

#include <iostream>
using namespace std;
int main ()
{
int y[10], n, i, max, min;
cout<<"\n N="; cin>>n;
for (i=0; i<n; i++)

{
cout<<"\n Y["<<i<<"]=";
cin>>y[i];
}
min=y[0];
max=0;
for (i=0; i<n; i++) {
if ( max<y[i] )
{
max = y[i];
}
if ( min>y[i] )
{
min = y[i];
}
}
cout << "Summa max i min = " << max+min << endl;
system("pause");
return 0;
}

Ответить

Другие вопросы из категории

Назовите исполнителей следующих видов работы : уборки мусора во дворе; перевозки пассажиров; выдачи заработной платы ; приема экзаменов; сдачи экзаменов;

обучения детей в школе.Попробуйте сформулировать СКИ для каждого из этих исполнителей.
пожалуйста.

повтори 4 [ Вперед 10 Направо 60 вперед 10 направо 60]

Исполнитель черепашка
Какая фигура появится на экране?
1)правильный треугольник
2)квадрат
3)правильный шестиугольник
4)незамкнутая ломаная линия

Известны координаты вершин A, B, C треугольника. Напишите программу, вычисляющую площадь этого треугольника.

Пример входных данных: xa=2 ya=1 xb=6 yb=5 xc=10 yc=1
Пример выходных данных: S=16.0

Читайте также

Задача №1

Заполнить массив размерностью 20 случайным образом числами от 0 до 150. Найти сумму максимального и минимального элементов массива.

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

Помогите пожалуйста, на завтра.

Найти для каждой строки матрицы сумму максимального и минимального элементов.

Напишите следующую программу. Введите с клавиатуры целое число N. Выведите на экран числа от 1 до N так, чтобы каждое число выводилось столько раз, каково

его значение. Например, если с клавиатуры введено 6, то на экране мы должны увидеть: 1 2 2 3 3 3 4 4 4 4 5 5 5 5 5 6 6 6 6 6 6
Написать программу нужно как можно проще в программе PascalABC



Вы находитесь на странице вопроса "С клавиатуры вводится список. Найти сумму максимального и минимального элементов списка. Выведите на экран полученный список. (С++)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.