Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дана строка. Поменять местами первый символ с последним символом этой строки.

10-11 класс

Сталкерсержант2002 06 янв. 2014 г., 3:32:11 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jene65
06 янв. 2014 г., 5:17:26 (10 лет назад)

Это выглядет вот так:
var s:string;
c:char;
begin
readln(s);
c:=s[1];
s[1]:=s[length(s)];
s[length(s)]:=c;
write(s)
end.

Ответить

Другие вопросы из категории

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

Читайте также

Дан массив целых чисел из 15 элементов, заполненный случайным образом числами из промежутка [ -20, 50 ].

Удалить из него все элементы, в записи которых есть цифра 5.
Вставить число k после всех элементов, кратных своему номеру (k вводится с клавиатуры).
Поменять местами первый положительный и последний отрицательный элементы.

с клавиатуры вводят слово.Составить программу ,которая: а)определяет количество символов в нём б)проверяет,не совпадают ли первая и

последняя буквы слова

в)выводт на экран первый,второй и последний символы

г)определяет,чётно или нечётно количество символов в нём

1. Помогите исправить ошибки и нарисовать блок-схему. Задание: дана матрица целых чисел размером

4х4. Поменять местами первый и последний элемент массива х.

Листингпрограммы:

ПОМОГИТЕ! Нужно написать программу в паскале. 1. Поменяйте местами первый элемен массива А(8) с наибольшим элементом, а

последний - с наименьшим элементом массива. Случайные числа в [10;99]

2. Посчитайте сумму чётных элементов массива А(8). Случайные числа в [1;9]

3. Найдите номер нулевого элемента данного одномерного массива А(10). Случайные числа в [-10;10]



Вы находитесь на странице вопроса "Дана строка. Поменять местами первый символ с последним символом этой строки.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.