Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите отредактировать программу - Паскаль. Где-то ошибка.

5-9 класс

Необходимо удалить первый кратный 3 элемент массива.
program udalenie;
var i,n,k:integer;
a:array[1..1000] of integer;
begin
assign (input,'input.txt');
assign (output,'output.txt');
reset (input);
rewrite (output);
readln(n);
for i:=1 to n do read (a[i]);
while i<=n do
if a[i] mod 3=0 then
begin
for i:=k to n-1 do
a[i]:=a[i+1];
n:=n-1; exit;
end;
for i:=1 to n do write(a[i],' ');
close (input);
close (output);
end.

Marikone 20 июня 2014 г., 12:10:42 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Managaku
20 июня 2014 г., 13:23:01 (9 лет назад)

Если первый кратный 3, то после срабатывания условия if a[i] mod 3=0 и удаления элемента, должен быть выход из цикла(break).

Ответить

Читайте также

пожалуйста помогите очень надо!!! В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого

дешевого(дорогого) товара и его индекс.

вот программа но в ней где-то ошибка

program xxx;

var a:array [1..10] of integer;

i, max, min:integer;

begin

for i:=1 to 10 do read(a[i]);

min:=1;

for i:=2 to 10 do

if a[i]<min then min:=a[i];

writeln('a[',i,']=',a[i]);

max:=a[i];

for i:=2 to 10 do

if a[i]>max then max:=a[i];

writeln('a[',i,']=',a[i]);

end.

Помогите, с помощью паскаля надо сделать следующее:

Составить программу, решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
Так же:
Составить программу, решающую следующую задачу: дан номер некоторого года (целое положительное число). Определить соотв-щий ему номер столетия, учитывая, что, к примеру, началом 20го столетия был 1901 год. Сам то я знаю как решать, но не смогу записать это в паскаль!

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.








Вы находитесь на странице вопроса "Помогите отредактировать программу - Паскаль. Где-то ошибка.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.