Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

в таблице А10 сравнить количество положительных и отрицательных элементов

10-11 класс

88Настёна88 04 апр. 2014 г., 20:29:44 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lia1164
04 апр. 2014 г., 21:58:49 (10 лет назад)

если массив 10 то размерность тоже 10

Ответить

Другие вопросы из категории

Скажите по конкретнее, что нужно знать чтобы научиться программировать в Pascal - что именно нужно изучить...

У нас на первом курсе тема Pascal, а я гляжу на него как баран на новые ворота...
Я отстал сильно на 2 недели и ни могу ни как понять его... Скажите пожалуйста по конкретнее с чего начать, что именно нужно изучить или выучить, понять, чтобы знать как составлять на нём программы ?

Распишите каждую строчку задачи ребят, задача решена в языке С.

#include
main() {
const n=10;
int a[10]={5,3,-6,2,-4,3,-7,4,8,-9};
int i,k=0,s=0;
long p=1;
for(i=0; i if (a[i]>0) {k++; s+=a[i];}
else if (a[i]<0) p*=a[i];
printf ("kol=%d, sum=%d, prod=%d",k,s,p);
}

проверьте, правильно ли я решаю)

Читайте также

Написать программу на Pascal ABC.Дан целочисленный массив размера N. Вычислить сумму и количество положительных элементов,

произведение и количество отрицательных элементов, произведение элементов до
первого отрицательного. Отсортировать массив по возрастанию.



Вы находитесь на странице вопроса "в таблице А10 сравнить количество положительных и отрицательных элементов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.