Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

найдите среднее арифметическое трёх чисел, ведённых с клавиатуры

10-11 класс

в паскаль

Koma12012 15 нояб. 2016 г., 0:20:45 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Wwwmatvei
15 нояб. 2016 г., 1:04:40 (7 лет назад)

var a, b, c,rez: real;
begin
writeln( 'Введите три числа' );
read ( a, b, c );
rez := ( a + b + c ) / 3 
writeln ('ср. знач.=', rez:0:2 ); 
end.

Ответить

Другие вопросы из категории

как разделить 8 литров подсолнечного масла на две равные части по 4 литра,если кроме полного 8-литрового бидона есть два пустых бидона на 5 литров и 3 л

итра?

Операция 8 л 5 л 3 л

до перелива 8 0 0

1-ый перелив

2-й перелив

3-й перелив

4-й перелив

5-й перелив

6-й перелив

7-й перелив

Помогите решить ,спасибо.

Метеорологическая станция ведет наблюдения за влажностью воздуха. Результатом одного измерения является число от 0 до 100 (%), которое записывается при

помощи минимально возможного количества битов. Станция сделала 80 измерений. Определите информационный объем результатов наблюдений.

1) 30 битов 3) 210 битов

2) 21 байт 4) 168 байтов

Procedure TFrmCalc.BtnPlusClick(Sender: TObject);

begin FrmCalc.LblPlus.Visible:=True;
FrmCalc.LblMinus.Visible:=False;
FrmCalc.LblDel.Visible:=False;
FrmCalc.LblUmn.Visible:=False;
FrmCalc.LblA.Caption:=(StrToInt(FrmCalc.EdtCh1.Text)+StrToInt(FrmCalc.EdtCh2.Text));
end;

Выдает ошибку :
Error: Incompatible type for arg no. 1: Got "LongInt", expected "TTranslateString"

Подскажите кто-нибудь , В чем ошибка (?), Ставил IntToStr , только тип Float не пробовал .

Читайте также

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

Введите с клавиатуры одномерный массив S(K), элементами которого являются положительные и отрицательные числа. Найдите среднее арифметическое значение

среди последних 9-ти элементов массива, максимум среди первых 5-ти элементов. Замените в массиве все элементы, которые больше найденного среднего арифметического - на максимум.

Помогите исправить программу. Она должна вычислять среднее арифметическое всех чисел в массиве меньших 50. Вот программа:

Program Zadacha;
Uses crt;
var a:array[1..1000] of integer;
c,i,n,s :integer;
s1: real;
begin;
clrscr;
writeln("Введите размерность массива);
readln(n);
writeln('Введите массив');
for i:=1 to n do
begin a[i]:=random(100);
if a[i]<50 then begin inc(c); s:=s+a[i];end;s:=s+a[i];s1:=s/N;
writeln('Массив A:');
for i:=1 to N do write(a[i]:4);
writeln;
writeln('Среднее арифметическое равно=',s1);
end;
end.

Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты. Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел. Если произведение этих четырех чисел больше их суммы, то выведите эти сумму и произведение. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму. Иначе, выведите удвоенные значения этих чисел.



Вы находитесь на странице вопроса "найдите среднее арифметическое трёх чисел, ведённых с клавиатуры", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.