Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать рекурсивную программу, которая:

10-11 класс

ромралпро 16 апр. 2013 г., 13:29:55 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nataliakostina
16 апр. 2013 г., 14:50:42 (11 лет назад)

#include<iostream>
using namespace std;
int d(int);
int main()
{
cout<<"enter...";
int i;
cin>>i;
cout<<d(i*2)<<endl;
system("pause");
return 0;
}
int d(int n)
{
if(n==2)
return 2;
else
return d(n)*d(n-2);
}

Ответить

Другие вопросы из категории

Известны фамилии и инициалы директоров каждой из 121 школы. Оформить лист 1 таким образом, чтобы можно было по номеру школы, задаваемому в одной из ячеек,

получать в другой ячейке фамилию и инициалы директора этой школы. НУЖНА ФОРМУЛА ДЛЯ EXCEL

задание по Объектно-ориентированному программированию на Делфи 7

добрый вечер, уважаемые школьники, студенты, а также все посетители этого замечательного сайта (надеюсь прочитать ответы от программистов). всем хорошего настроения. и я бы хотела, чтобы мне помогли написать программу на языке Делфи 7 в консольном режиме (этот режиме нету дизайна и он похож на обычный Паскаль).

задание:
Даны координаты вершин двух треугольников. Определить, какой из них имеет большую площадь.

я прикрепила файл "Уточнение задания" - там всё конкретно описано.

заранее спасибо всем за помощь.

Читайте также

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

Написать программу, которая выводит таблицу квадратов первых десяти целых положительных чисел (естественно, квадраты должны считаться В ЦИКЛЕ!). Ниже

представлен вид экрана во время работы программы, который вам нужно реализовать:

Таблица квадратов
-----------------------------
Число Квадрат
-----------------------------
1 1
2 4
и т.д.

Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию.

Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.



Вы находитесь на странице вопроса "Написать рекурсивную программу, которая:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.