Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Упорядочить последовательность по убыванию элементов и выдать на экран все элементы, большие некоторого заданного числа. И вот как раз это некоторое

10-11 класс

заданное число я взяла "с=2000". Не могу написать часть программы, которая бы как раз и обозначала вывод на экран последовательность чисел, которые были бы больше заданного числа.. :(

Program mas1;
uses crt;
Var a: array [1..30] of real;
i,n,P,k,c: integer;
d: real;
Begin
repeat
Write(' Введите 0 Readln(n);
if (n<0) or (n>30) then
writeln(' n неправильно введено');
until (n>=1) and (n<=30);
P:=2;
For k:=1 to n do
Begin
P:=P*(k+2);
a[k]:=P*cos(k);
end;
writeln(' Получен массив А');
for i:=1 to n do
writeln('A[',i:2,']=',A[i]:15:3);
writeln;
For i:=1 to n do
for k:=1 to n-i do
if a[k] begin
d:=a[k];
a[k]:=a[k+1];
a[k+1]:=d
end;
writeln;
writeln(' Массив по убыванию');
for i:=1 to n-1 do
writeln('A[',i:2,']=',A[i]:15:3);
writeln;
c:=2000;

?

end.

Mamaga 19 февр. 2017 г., 8:28:56 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Iopqa
19 февр. 2017 г., 10:13:14 (7 лет назад)

вот держи.там пояснил немного.если есть вопросы-задавай

Ответить

Другие вопросы из категории

что означает ##### в excel
подскажите 14 и 15 пожалуйста
Заполнить двухмерный массив размером 6 × 6 следующим образом:

1 1 1 1 1 1
1 1 0 0 0 1
1 0 1 0 0 1
1 0 0 1 0 1
1 0 0 0 1 1
1 1 1 1 1 1

!ответ!
uses crt;
const n=6;
var i,j,k: integer;
a: array [1..6,1..6] of integer;
begin
for i:=1 to n do
begin
for j:=1 to n do
begin
if (i=j) or (j=1) or (i=1) or (i=6) or (j=6) then
a[i,j]:=1
else
a[i,j]:=0;
write(a[i,j]:3);
end;
writeln;
end;

Читайте также

Задан одномерный массив А(N) (N<=60). На место минимального элемента массива записать сумму последних К элементов массива. Если А[1]>=0, то умножить

все элементы этого массива на квадрат минимального элемента данного вектора, а если А[1]<0, то умножить все элементы на квадрат максимального элемента вектора. Полученный массив распечатать. Значение К вводится пользователем.

Помогите написать программу в паскале. За ранее спасибо. Задача на одномерный массив. Задание 4. В одномерном массиве А[1..12]

необходимо поменять местами: а) первый и последний элементы массива; б) второй и минимальный элементы массива; в) третий и максимальный элементы массива; Вывести на экран исходный и результирующий массивы.

эллементы массива вычисляются по формуле A(X,Y)=2X^2-Y^2 написать программу, которая выводит на экран значения элементов массива А(2,2).

подсчитать количество отрицательных элементов

сумму положительных элементов

ВЫВОДИТ НА ЭКРАН НОМЕРА ВСЕХ ЭЛЕМЕНТОВ, ЗНАЧЕНИЯ КОТОРЫХ =0

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.



Вы находитесь на странице вопроса "Упорядочить последовательность по убыванию элементов и выдать на экран все элементы, большие некоторого заданного числа. И вот как раз это некоторое", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.