Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите написать программу в паскале: Подсчитайте количество слов, начинающихся и заканчивающихся одной и той же буквой.

10-11 класс

Petrushckalena1982 29 дек. 2013 г., 3:32:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Britik7
29 дек. 2013 г., 4:42:24 (10 лет назад)

var
  i,n,k:integer;
  s:string;
begin
readln(s);
s:=s+' ';
k:=1;
for i:=2 to length(s) do
  if (s[i]=' ') and (i>k+1) then
     begin
     if s[k]=s[i-1] then n:=n+1;
     k:=i+1;
     end;
writeln(n);
end.

Ответить

Другие вопросы из категории

помогите прошуууу))))
1.Составьте таблицу истинности для логического

выражения ¬(¬A & ¬B) & ¬(¬A & ¬B)
2.Преобразуйте логическое выражение используя законы алгебры логики.

Читайте также

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

Помогите написать программу в паскале!Очень надо!

Задана последовательность целых чисел,количество которых не превосходит 100.Требуется определить за один проход элемент с максимальным значением,а также число его повторений в последовательности.



Вы находитесь на странице вопроса "помогите написать программу в паскале: Подсчитайте количество слов, начинающихся и заканчивающихся одной и той же буквой.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.