Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Найти максимальный элемент массива X(10).

1-4 класс

помогите написать программу в паскале пожалуйста.

Tanzee 04 июня 2014 г., 7:15:45 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Pasha200483
04 июня 2014 г., 7:55:43 (9 лет назад)

var
X: array [1..10] of integer;
a,s,i: integer;
begin
randomize;
write('Хотите заполнить массив самостоятельно? (1) Или автоматически? (2)');
readln(s);
case s of
  1: begin
     writeln('Введите 10 элементов массива: ');
     for i:= 1 to 10 do readln(X[i]);
     a:=X[1];
      for i:= 1 to 10 do
       if a < X[i] then a:=X[i];
     writeln('Максимальный элемент: ',a);
     end;
 2: begin
     writeln('Массив: ');
     for i:= 1 to 10 do
     begin
      X[i]:=random(101);
      write(X[i]:4);
     end;
    writeln;
    a:=X[1];
     for i:= 1 to 10 do
       if a < X[i] then a:=X[i];
     writeln('Максимальный элемент: ',a);
     end;
  end;
end.     

Ответить

Другие вопросы из категории

Помогите пож!

1.управляющий объект-это?
•Объект который исполняет команды
• Объект который управляет
•Объект на который направлено управляющее воздействие
2. Объект управления-это?
• Объект который дает команды
• Объект который управляет
• Объект на который направлено управляющее воздействие
3. Цель управления-это ожидаемый_______ управления.
Цель управления -это то, к чему стремится управляющий объект,когда оказывает на ______ управления управляющее_______.
Слова для справки:воздействие,объект,результат.

инфоматика №110№110

Запишите полные имена всех файлов. размещённых на диске файловая структура которого имеет следующий вид

Читайте также

Задачка в abc pascal, прошу написать полную программу от начала и до конца Сформируйте массив по правилу: элементы массива P(a) равны

своим индексам, увеличенным на один. Значение a описать в разделе констант. Выведите массив в строчку.



Вы находитесь на странице вопроса "Найти максимальный элемент массива X(10).", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.