Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

на языке программирования Паскаль составить программу для перевода числа из 10-чной системы счисления в систему счисления с основанием 12 или

5-9 класс

16 (количество разрядов на ваше усмотрение).

Ulkor79 15 февр. 2014 г., 0:08:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vsevolod497
15 февр. 2014 г., 2:50:39 (10 лет назад)

Program a1;
Uses crt;
function sc(i,vr:integer):integer;
var cic,p:integer;
begin
p:=1;
if i>1 then
For cic:=1 to i-1 do
p:=p*16;
result:=vr*p;
end;

var
b: set of 'a' .. 'z';
c:set of '0'..'9';
ch,s,l,vr,i:integer;
sr:real;
s1,s2:string;
z:char;
otvet:longint;
Begin
Write('Введите число, s1= ');
Readln(s1);
l:=length(s1);
While l>0 do
begin
s2:=s2+s1[l];
l:=l-1
end;
l:=length(s2);
For i:=1 to l do
begin
z:=s2[i];
If (ord(z)>96) and (ord(z)<123)
then
begin
case z of
'a': begin
vr:=10;
otvet:=otvet+sc(i,vr);
end;
'b': begin
vr:=11;
otvet:=otvet+sc(i,vr);
end;
'c': begin
vr:=12;
otvet:=otvet+sc(i,vr);
end;
'd': begin
vr:=13;
otvet:=otvet+sc(i,vr);
end;
'e': begin
vr:=14;
otvet:=otvet+sc(i,vr);
end;
'f': begin
vr:=15;
otvet:=otvet+sc(i,vr);
end;
end;
end else
if (ord(z)>47) and (ord(z)<57) then
begin
vr:=strtoint(z);
otvet:=otvet+sc(i,vr);
end;
end;
Writeln('Ответ = ',otvet);
End.

Ответить

Другие вопросы из категории

информатика, не шарю
Второе, пожалуйста помогите)
Статья, набранная на компьютере, содержит 16

страниц, на каждой странице 28 строк, в каждой строке 64 символа, каждый символ
кодируется 16 битами. Определить информационный объем статьи.

Читайте также

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

№1 Семенова Анастасия 1. Закодировать свои имя и фамилию следующим образом: А = 1, Б = 2, В = 3, ….. , Ю = 32, Я = 33.

2. Найти сумму ГЛАСНЫХ букв своей фамилии.
3. Найти сумму СОГЛАСНЫХ букв своего имени.
4. Перевести сумму букв фамилии ИЗ ДЕСЯТИЧНОЙ СС В ДЕВЯТИРИЧНУЮ СС
5. Перевести сумму букв имени ИЗ ДЕСЯТИЧНОЙ СС В ДВЕНАДЦАТИРИЧНУЮ СС.

6. Найти сумму букв своей фамилии по алгоритму от 22.04.2013г.
7. Возвести в степень 3/2 полученное число.
8. Целую часть полученного десятичного числа перевести последовательно в 2-ную, 3-ную, 7-ную, 12-ную и 16-ную системы счисления.
9. Сделать вывод на основе полученых результатов.

№2На языке программирования Паскаль составить программу перевода из десятичной системы счисления в систему счисления с основанием Х,
где Х - целое число, определяемое по такому правилу:
если 2-я буква фамилии учащегося находится в интервале от А до Д, то Х = 9;
если 2-я буква фамилии учащегося находится в интервале от Е до К, то Х = 8;
если 2-я буква фамилии учащегося находится в интервале от Л до Р, то Х = 7;
если 2-я буква фамилии учащегося находится в интервале от С до Ц, то Х = 6;
если 2-я буква фамилии учащегося находится в интервале от Ч до Я, то Х = 5.

Помогите с информатикой! Нужно cоставить программу на языке программирования (Паскаль) с ветвлением

ЗАДАЧА - Составить программу решения задачи: Z = m/(m-1)
ЗАДАЧА - Составить программу определения четных (нечетных) чисел



из математической записи создать запись на языке программирования.

а)2,136+2/3y
б)(x-5)+a/3ax
Например:
Математическая запись: Запись на языке программирования:
a+3b-2c (a+3 умножить на b-2 умножить на c):(7 умножить на a+2)
Срочно!



Вы находитесь на странице вопроса "на языке программирования Паскаль составить программу для перевода числа из 10-чной системы счисления в систему счисления с основанием 12 или", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.