Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Из 16-ти чисел, спросите у пользователя ,сколько нужно проанализировать чисел, а затем запросите эти числа и сделайте для каждого вывод, является ли

10-11 класс

оно четным или отрицательным.(Паскаль)

Или так: Из 16 -ти чисел,сделайте для каждого вывод,является ли оно четным или отрицательным .(Паскаль)

Помогите пожалуйста,оченьььь срочно надо!Буду благодарна за решение ,спасибо!!!!!!!

окси03 02 мая 2014 г., 19:59:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mulyar2004
02 мая 2014 г., 21:48:27 (9 лет назад)

var a:array[1..16] of longint;

i:longint;

begin

for i:=1 to 16 do

read(a[i]);

for i:=1 to n do

if (a[i] mod 2=0)or (a[i]<0) then writeln(a[i]);

end;

+ 0 -
1234yBa4oK123
02 мая 2014 г., 22:33:17 (9 лет назад)

var
a: array[1..16] of integer;
i:integer;
c,r,s:real;
begin
writeln('vvedite 16 zisel');
for i:=1 to 16 do
readln(a[i]);

for i:=1 to 16 do begin
write(a[i], ' ');
if a[i] mod 2 = 0 then
write('chetnoe, ')
else
write('ne chetnoe, ');
if a[i]>= 0 then
write('polozitelnoe, ')
else
write('otrezatelnoe, ');
writeln()
end;
end.

Ответить

Другие вопросы из категории

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

1) Сколько следует задать вопросов и как их следует формулировать, чтобы количественно оценить сообщение о том, что вагон стоит на одном из 16 путей?

2) Вы бросаете два кубика с нанесенными на гранях цифрами от 1 до 6. Определите, сколько битов информации несет сообщение о том, что на одном кубике выпала тройка, а на другом- пятерка.
3) Предположим, вероятность того, что вы получите за контрольную работу оценку "5", равна 0,6; вероятность получения "4" равна 0,3; вероятность получения "3"-0,1. Определите, сколько битов информации будет нести сообщение о результатах контрольной работы в каждом из вариантов. ПОЖАЛУЙСТА, ПОМОГИТЕ!!!

Люди добрые помогите пожалуйста(сделайте подробно)

1.Какое количество информации получит игрок, которому из колоды в 32 карты
достают короля пик? А если то же, но из колоды в 36 карт?
2. В рулетке общее количество лунок 128. Какое количество информации мы получаем, увидев, что шарик остановился в 25 черное?
3.Сколько страниц в брошюре, если сообщение о том, что случайно открылась 17 страница содержит 6 бит информации?
4. Сколько нужно задать вопросов, чтобы угадать натуральное число не более 100?

ПОМОГИТЕ ПОЖАЛУЙСТА,ОЧЕНЬ НАДО Вы подошли к развилке из четырех дорог. Вы выбрали самую левую дорогу. Какое количество информации вы при этом получили?

2. Сколько килобайтов составит сообщение из 384 символов 16-ти символьного алфавита?



Вы находитесь на странице вопроса "Из 16-ти чисел, спросите у пользователя ,сколько нужно проанализировать чисел, а затем запросите эти числа и сделайте для каждого вывод, является ли", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.